Domain Mapping not saving - twirling icon displays

Hi

I have been struggling for 3 days now and am at my wits end.

I have a new multisite installation of wordpress (4.1) on my site http://zenten.biz
I assume that the DNS is setup correctly because when I navigate to my dedicated IP
http://192.169.60.183 my site displays correctly.

I then installed the Domain Mapping plugin (4.2.0.6) using the standard plugin from the WPMU Dev Dashboard and moved the sunrise.php from the domain-mapping folder to the wp-content folder and edited the wp-config.php file as follows
define('SUNRISE', 'on':wink:;

/* That's all, stop editing! Happy blogging. */

I then edited the DNS for my domain beautifulhands.co.za as follows:
@ A 192.169.60.183
www A 192.169.60.183
* A 192.169.60.183

When I navigate to the website http://beautifulhands.co.za. the zenten.biz wordpress site displays, prompting me to login to register the new site.

I then login as the superadmin and register the site as beautifulhandscoza.zenten.biz.
I then login as the superadmin on the http://beautifulhandscoza.zenten.biz and go to the WP Admin dashboard for that site.

I click Tools -> Domain Mapping and enter the domain name (beautifulhands.co.za) in the textbox and click the Map Domain button. The twirling icon displays and never goes away.

When I check the database the domain_mapping table has no records in it. (the icon is still twirling even after 10 minutes)

I manually added the record to the database as follows:

id 1
blog_id 2
is_primary 1
domain beautifulhands.co.za
active 1
scheme 0

When navigating to http://beautifulhands.co.za it correctly displays the site that was created, but when I go to the Mapped Domains tab for the site, it displays only the blog id and all the other columns are empty.

When I go to the Tools -> Domain Mapping menu item on the http://beautifulhands.co.za WP Admin it displays nothing except a hyperlink to http://beautifulhands.co.za with http as the only text (see attached image).

I also tried with a different domain (generaltransport.co.za) but it also just displays the twirling icon. I don't want to manually enter the domain mapping record in the db.

I have tried various combinations as below with no luck
Deactivating and Reactivating the plugin
deleting and reinstalling the plugin
deleting the wordpress database and reinstalling wordpress

I initially activated Pro Sites plugin first, but have since uninstalled it, thinking it was causing a mismatch.

Please help. I don't know what to try next.

Regards

Douglas