Domain Mapping Not Working

* I Installed WordPress MU Domain Mapping plugin.
* Added the following line in wp-config.php file.
define( 'SUNRISE', 'on' );
* Copied sunrise.php from Domain-mapping plugins folder to wp-content folder
* After this, I went to Network Admin >> Dashboard >> Settings >> Domain Mapping menu.
* On next screen, I entered the IP address of my server .
* Then I went into the individual site Dashboard >> Tools >> Domain Mapping. I entered new Domain name to Sub-Domain site.
* I get a message that says, "New domain added," but it doesn't not show the original sub-domain or new domain as seen on some Youtube Videos.

FYI: A wildcard has already been created in cPanel

* I went to cPanel and created a new aliases.

When I visit the site the sub-domain is showing not the new domain.

When I go to Network Admin all Sites. There is nothing under the mapping column.

  • Kasia Swiderska

    Hello Susan,

    * On next screen, I entered the IP address of my server .

    Do you have dedicated IP address that points directly to your Networks main site? So when you type in browser your IP your Multisite opens?

    * I get a message that says, "New domain added," but it doesn't not show the original sub-domain or new domain as seen on some Youtube Videos.

    Did you follow instruction from usage page https://premium.wpmudev.org/project/domain-mapping/#product-usage under A Record & CNAME section? I don't see that in steps you provided. If you don't add those records when you have dedicated IP domains will not be mapped.

    If you don't have dedicated IP you need to add domain in your cPanel as add-on and point it to root directory of your network.

    If you done configuration in your cPanel and it still doesn't work would you mind allowing support access so we can have a closer look at this? Also leave message for support what domain should be mapped to what subsite.
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Ash

    Hello Susan

    If you don't have dedicated IP, you can use nameserver - no need to use A record.

    Let me simplify the procedure.

    For example, your main site is network.com
    You have two subsites:
    1. one.network.com
    2. two.network.com
    These two subsites you want to map with following domains repectively:
    1. one.com
    2. two.com

    So, if anyone enter one.com in the browser, it should show the site of one.network.com. Same for two.com

    network.com site is hosted in a hosting whose nameservers are:
    ns1.networkhost.com
    ns2.networkhost.com

    So, you have entered these nameservers for network.com domain panel. You have to set same nameservers for one.com and two.com domains too.

    Then you will add one.com and two.com domains as parked on domain in the same hosting of network.com, and make sure you point them to the network.com wordpress root folder. So that if any one enter one.com or two.com it shows network.com site.

    After that, you will add the domains in corresponding subsites using domain panel plugin, and the mapped domain will start working.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • Susan

    I'm a little lost. Currently this is where I'm at.

    cPanel
    I've gone into Simple Zone Editor and added a CName.
    I've created a new Alias. Domain Root: ( /public_html)
    Added : define( 'SUNRISE', 'on' ); into wp-config.php file
    Moved sunrise.php file to wp-content folder

    WordPress
    Installed and activated WordPress MU Domain Mapping Plugin
    Clicked on Domain Mapping on Network Admin...but I don't know where to go from here.

    I understand I don't put in a Server IP Address: because I don't have a dedicated IP.
    What do I put into Server CNAME domain: ?

  • Kasia Swiderska

    Hello Susan,

    Please take a look again on the Ash answer https://premium.wpmudev.org/forums/topic/domain-mapping-not-working-19#post-1150610
    First check what is your network domain DNS name server - if you dont know that ask your hosting provider or domain provider.

    When you have those names you need to set the same nameservers for domain you want to map.

    Next step is to add those domain in your cPanel as Parked domain

    They need to be pointed to Domain Root (no own directory) - it has to be directory where your network is installed.

    If you bought your new domain in the same hosting provider and that domain is available already in your cPanel - you can add that domain as Add-on (not parked domain) and you don't need to set up any nameserver.

    Clicked on Domain Mapping on Network Admin...but I don't know where to go from here.

    This is for Domain Mapping configuration - you map domain in subsite Dahsboard. Go to Tools -> Domain Mapping. You will see there place to add domain you want to map. So you map domain in subsite, not in Network.

    I understand I don't put in a Server IP Address: because I don't have a dedicated IP.
    What do I put into Server CNAME domain: ?

    You don't use CNAME when you don't have dedicated IP.

    kind regards,
    Kasia

  • Susan

    I'm still unable to map domain correctly.
    Current URL: dedicatedlandscapers.395plazacom
    I would like to map it to
    NEW URL: dedicatedlandscapers.com

    Currently in cPanel I have done the following.
    Subdomains: I added wildcard, *.395plaza.com
    Aliases: I added, dedicatedlandscapers.com pointed to /public_html
    Simple Zone Editor: Added subdomain to NAME and dedicatedlandscapers.com to CNAME.

    I don't think I can change the URL from the
    Network Admin > Sites
    Because I if I do this I can access the "New Site," but not the "Dashboard."
    When you try to access the Dashboard it prompts you to log back in and when I try to log back in. I get the following error.
    "ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress."
    If I change the URL back to dedicatedlandscapers.395plaza.com, then I can get back to the Dashboard.
    I believe that in the Network Admin > Sites the URL needs to remain dedicatedlandscapers.395plaza.com, but the column that says, "mapping" needs to say, dedicatedlandscapers.com.

    I just don't know how to do this?

    Ash you said, "So, you have entered these nameservers for network.com domain panel. You have to set same nameservers for one.com and two.com domains too."
    How do I do this? Yes, I know the nameserver, but where do I set this?

    Kasia, you said, "When you have those names you need to set the same nameservers for domain you want to map."
    How do I do this? Yes, I know the nameserver, but where do I set this?

    I installed WPMUDEV Plugin and nobody has helped me via this plugin. All the help I've gotten has been through this Forum. I thought if I installed WPMUDEV Plugin someone could look at my Wordpress and see what I've done thus far and help me. How do I get this kind of help?

  • Kasia Swiderska

    Hello Susan,

    I believe that in the Network Admin > Sites the URL needs to remain dedicatedlandscapers.395plaza.com, but the column that says, "mapping" needs to say, dedicatedlandscapers.com.

    Go to Dashboard of the dedicatedlandscapers.395plaza.com subsite and then to Tools -> Domain Mapping and there add domain you want to map.

    Kasia, you said, "When you have those names you need to set the same nameservers for domain you want to map."
    How do I do this? Yes, I know the nameserver, but where do I set this?

    You set that in your domain management panel - that depends on service provider. In SiteGround it will look different that in for example BlueHost, so I cannot make a screenshot for you.
    You should be able to get that information from support of your domain provider.

    But I suspect that you can try second way (I described here) if you bought domain from the same company where you bought hosting and instead of changing nameserver you can add Add-on domain.

    Aliases: I added, dedicatedlandscapers.com pointed to /public_html
    Simple Zone Editor: Added subdomain to NAME and dedicatedlandscapers.com to CNAME.

    Remove Alias and those records - you don't have dedicated IP to use CNAME - and choose Add-on domain and there add this domain and point to /public_html.

    If you still have trouble configuring domain then please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include cPanel credentials
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me. Please confirm in thread that you send those credentials

    I installed WPMUDEV Plugin and nobody has helped me via this plugin. All the help I've gotten has been through this Forum. I thought if I installed WPMUDEV Plugin someone could look at my Wordpress and see what I've done thus far and help me. How do I get this kind of help?

    Susan, we can access only your WordPress Dasboard with WPMU DEV Support access and see if settings there are correct. But we are not able to do anything if your domains are not configured correctly - if you are sure that domain are OK, and domain mapping still doesn't work - then support access is used.

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Susan,

    I'm terribly sorry for delay on our end. Thank you for sending credentials. I however have a bad news. That plugin you are using is not working - but not because the wrong configuration!
    Right now if you go to your domain you want to map you will see that main site of your network is opening with signup form. That means the add-on domain is working - but Domain Mapping plugin is not, because it doesn't add domain to mapped domain. There is no error, but domain is not showing on the mapped domain list. So I checked that plugin page and it wasn't updated for last 2 year.
    At the moment we can try to trouble shoot why plugin is not working, but it will take time and there are two other solutions that can be used instead:
    1) Use our Domain Mapping plugin https://premium.wpmudev.org/project/domain-mapping/ - your domain is already configured, so it will require installing plugin and adding this domain to mapped domains.
    2) If you don't need to map more than one domain to your subsite you can use WordPress native way for domain mapping. This has some disadvantages - cross domain login will stop working (so you will have to login separately to that subsite) and you can only map one domain. This will be the quickest way to do:
    a) go to your sites list
    b) edit your subsite

    c) change Site Address (URL) to mapped domain

    d) Save.
    You will be logged out - and the you will need to log back using your mapped domain.

    Let me know which way would you like better and we follow with it.

    If you go to cPanel - to add-on domaisn you will see that your domain is added there and it points to public_html directory - each next domain has to be added the same way.

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Susan,

    You don't need to remove plugin from cPanel - do it in your WordPress Network Dashboard. Go to this url /wp-admin/network/plugins.php

    Find Domain Mapping on the list. Deactivate it and then Delete it. After that there will be only left in wp-content file sunrise.php - this one remove from cPanel - our plugin also uses sunrise.php but it is different on.
    You will probably see warning in your WordPress panel about that file, but you can ignore it because after you will install Domain Mapping it will disappear.
    Follow instruction about installation here https://premium.wpmudev.org/project/domain-mapping/#product-usage
    Let me know if you have more questions about installation.

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Susan,

    That is great that its working now!

    To clarify - plugin that you were using before was not our plugin, it has different author - name is quite similar, but since WordPress can map domain in settings, that other plugin author stopped maintaining it. Our Domain Mapping is still giving more options than native way in WP, thus we are still developing it.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.