Domain Mapping Edits

Alright.. trying to get Domain Mapping to work, but without success. Here is the setup.

Native Apache environment.

I installed the plugin and set it up with the IP its located on (the WPMU has its own IP)

I point the domain with an A record in the DNS to exact same IP of the install.

I create a WP blog and login to the backend of the blog to input the domain.

All saves all is well. I attempt to visit the blog, but I get redirected back to the main WPMU page.

Same thing happens when I attempt to visit the subdomain of the blog created... redirects back to the the main TLD home page.

I have membership/supporter installed but not yet configured. I specified not to use supporter. Regardless of this, I believe it should be working.

Oh yes.. and I also added an apache config to the server and restarted it. Config pointed the domain to the exact same directory as the main home page. Still no love.

What do I do now?

Thanks.

  • drmike

    We would be helpful if we had some specifics like the domains in question, the ip address they're supposed to be at, etc.

    I installed the plugin and set it up with the IP its located on (the WPMU has its own IP)

    Are you trying to set it up for the mapped domain is on a different IP address than the wpmu install?

    Are you using some sort of hosting platform (ie CPanel?) to manage your setup? If so, how are you adding in your mapped domain to the platform?

  • VestedMediaGroup

    Sorry I can't do that in a public forum. If someone wants to personally PM with me to help and keep the site confidential then thats ok.

    Continuing here though:

    Are you trying to set it up for the mapped domain is on a different IP address than the wpmu install?

    No it's the same IP like I said, a dedicated one. I am aware that the plugin does support multiple IPs though. I do plan to utilize multiple (and dedicated) IPs in the future.

    Are you using some sort of hosting platform (ie CPanel?) to manage your setup? If so, how are you adding in your mapped domain to the platform?

    No, like I said.. it's a native linux apache setup. I guess I should have gone on to say CentOS 5.5 64 bit, Apache 2.2, PHP 5.2, and MYSQL running on it. No control panel, no funky modifications to the system done by cpanel or any other control panel.

    Domain DNS is controlled by the registrar, both for the WPMU and for the mapped domain. I added an A record to point at the exact same IP as the install of the WPMU, which as I mentioned, is hosted on its own dedicated IP address. Apache is setup as follows:

    NameVirtualHost 123.123.123.123:80

    <VirtualHost 123.123.123.123:80>
    ServerName domain.com
    Serveralias *.domain.com
    DocumentRoot /home/domain.com/
    </VirtualHost>

    The DNS of the mapped domain is pointing to only the mappeddomain.com address, there is no www involved anywhere. Even the main WPMU site does not use www for the main blog site.

    Here is the best part.

    I went back to check things again after reading this reply. For some reason the domain I had entered yesterday had just disappeared from the settings. So I put it back in. I went back to look again, and suddenly like magic, they are working now. Go figure. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.