Domain Mapping not working for me – Multisite

I setup a multisite network and added couple of test sites to it. Then I added the Domain Mapping plugin and configured it accordingly.

Now, when I open my Site A and go to tools, try to map an existing domain, I keep getting the error message of “Domain name is unavailable for access”. But, siteA.mysite.com URL continues to work fine.

I have a dedicated IP and have configured it too.

Please help in this setup.

  • Nastia
    • Support Rock Star

    Hello @deepti, I hope you are well!

    In Domain Mapping Settings , please check that “Verify domain’s DNS settings” is set to “NO”.

    Did you add your domain to a host provider as a Add-on domain or as Perked domain?

    What is the Health status of your Mapped Domain?

    Please advise,

    Kind Regards,

    Nastia

  • Deepti
    • New Recruit

    Alright, I made the change: “Verify domain’s DNS settings” and set to “NO”. I used this method of Addon domain, added a new addon domain into my hosting panel. Then I added a new site as addon.mysite.com. Then I created the mapping for it as per plugin and after sometime it starts opening the addon.mysite.com on the addon.com site. Works fine.

    However, in case I add a site before adding the subdomain then it keeps on loading the addon.com site only when I enter addon.mysite.com or addon.com site. I entered addon2.mysite.com which took me to a front end page saying no such site exist and showed me the list of all sites in network currently. Then I clicked on addon.mysite.com and it started opening properly and now when I enter addon.com it also points correctly. What happened here? Why when I opened from front end the mapping got corrected. What are the correct steps to Add a New Site? It should be done from front end or backend?

    Also, now I have another domain which I do not own but my friend does as externaltestdomain.com

    Now, he wants to use this domain and run site under my MU installation. What will be the steps here? Do we need to make any changes in my friend domain settings or hosting settings?

    What this plugin is doing that cannot be done when I am doing all this manual work always for both my owned domains as well as domain owned by my friend?

  • Nastia
    • Support Rock Star

    Hello @deepti, I trust you are well!

    Would you please grant support access from your Dashboard > WPMU DEV > Support > Support Access so that I can check?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please, send us your credentials so we could log in to your host.

    You can send credentials by using our secure contact form https://premium.wpmudev.org/contact/

    Subject: “Attn: Anastasia”

    -WordPress admin username

    -WordPress admin password

    -login url

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me

    https://premium.wpmudev.org/contact/

    Kind Regards,

    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.