Domain Mapping on a Virtual Server

I am setting up my WordPress MU and I have purchased a virtual server account. When I tried this on a shared hosting account the domain mapping wouldn’t work unless I added the domain name to my hosting account. Does anyone know if it will work now on virtual server without having to add it to the hosting account? Essentially I would like for it to be where my clients could map the domain name themselves through the WP dashboard account and adding the IP and nameservers to their domain name. Is that possible or could someone point me in a direction on how to make that possible.

  • aecnu
    • WP Unicorn

    Greetings susanshrop,

    Thank you for this great question and a significant item to bring up.

    All you need to do is have your clients set up an “A” record pointing to your VPS servers dedicated IP and the name servers stay where they are at by default.

    WordPress just manages the site but does not manage DNS, therefore setting the nameservers to you then one should forget about the “A” record because you would just park it in that event.

    Nameservers somewhere else = point ‘A” record.

    Using your own nameservers on the same server as WordPress installation = park the domain.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

  • Todd Heitner
    • The Incredible Code Injector

    I just wanted to point out that there is a little configuration you’ll have to do to make the domain mapping work. It’s more than just installing the plugin. I believe most of the details are in the readme file/setup instructions, but it can be a little confusing the first time through.

    You’ll need to make sure you have an IP address dedicated to your domain with your WP MultiSite installation. You might need to ask your host about it, or if you have WHM access you can usually do it through there.

    You also need to set up a wildcard subdomain. If you have cPanel access, you go to Subdomains and create a new subdomain that is just an asterisk * and point it to the root of your site, usually public_html.

  • aecnu
    • WP Unicorn

    Greetings Todd Heitner,

    Thank you for your additional input though it indeed contains a small error regarding the asterisk which is not relevant in any way, shape, or form to Domain Mapping.

    The rest of the information was correct and you attempt to help certainly appreciated.

    Thank you for being a WPMU Dev Member!

    Cheers, Joe

  • Todd Heitner
    • The Incredible Code Injector

    Sorry about that, setting up the wildcard subdomain is to make the subdomains work in a WordPress MultiSite environment. You have to do it to make the sites work if you’re using subdomains rather than subdirectories, but it’s not directly related to domain mapping. So sorry about the confusion.

  • susanshrop
    • Site Builder, Child of Zeus

    Ok… I have set up a virtual dedicated server and have everything set up. I have a dedicated IP on the account and the domain mapping plugin installed. I have pointed to IP address and nameservers to my account and added the domain name within the wordpress dashboard for that particular child blog. It is not coming up?

    I’m not sure what I missed. I have the dedicated server, the dedicated IP and the domain mapping plugin. The domain name is with GoDaddy, is there a special way to set the A record?

  • Todd Heitner
    • The Incredible Code Injector

    No, you shouldn’t change the name servers. You only need to change the A Record.

    If you’ve changed the name servers, go back and change it to “parked” at GoDaddy. Give that a few minutes to take effect. Once it does, you’ll be able to go into the DNS settings and point the A Record to your IP address.

    I don’t know if this will help you, but I made a little tutorial video for my users that you can watch just to see me going through the steps:

    http://www.youtube.com/watch?v=RC-jziMiXAo

    You don’t need to watch the whole thing, it’s for beginners, so skip to 2:20 and that’s where I talk about things on the GoDaddy side.

    I’m also using the wpmudev Easy Blogging plugin so the WP menu looks different, but you’ll get the idea.

  • susanshrop
    • Site Builder, Child of Zeus

    Great video! One question, when I do this the domain still doesn’t work. Do you also add the domain to your hosting account or does yours work automatically? My hosting company is telling me I have to add it to the hosting account.

    Is this where you were saying I need to do the wildcard thing?

  • Todd Heitner
    • The Incredible Code Injector

    Yes, if you’re using subdomains (instead of subdirectories) and you haven’t already set up the wildcard subdomains, you should do that.

    You don’t need to add it to your hosting account. They probably don’t understand what you’re doing. That would kind of defeat the purpose if you had to manually add each domain, the goal is to make things more automated and easier, right? :slight_smile:

    If you’re using the subdomain method, have you tested a site before trying domain mapping? If the sites don’t work without using a custom domain, then the problem is something else.

    If you haven’t already done so, I would suggest setting up a test site without using a custom domain name and see what happens. Then that will shed some light on what’s happening.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.