Domain Mapping P3 Plugin Usage as high as .5 load (30% of plugin usage)

We have an issue where our server load is gradually “filling up”. Basically the resources are being consumed very gradually and then the server’s usage spikes with and we have to restart one or more resources in LAMP (usually managed services point to RAM & PHP). The last restart was a APACHE services.

So I placed a question in another support forum area and someone suggested I run the P3 plugin and cross reference it with some load tools.

The only thing standing out at me as potentially odd is domain mapping. It as much as .5 second load and 30% of total plugin chart.

I am curious if this is usual for this plugin to take that much room? It seems to be running a little higher with a-record mapping rather than NS (maybe its a coincidence). I guess is if this plugin is not performing correctly it could possibly be bottlenecking resources in trying to resolve things?

I disabled logged in users are logged into all sites option thinking maybe that will help decrease the server load some.

Any thoughts?

  • Ash
    • WordPress Hacker

    Hello @maxwebgear

    I hope you are well today and thanks for asking the question.

    I think SSO is active in your site. This is what I got from the developer:

    When single sign on ( SSO ) is active in your settings page, this performance issue happens.

    On each page calls SSO needs to check to see if the user is logged in somewhere else and get the users logged in. Actually it’s a cost-value balance you should consider.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers

    Ash

  • maxwebgear
    • The Incredible Code Injector

    Ashok, sorry it’s late in the US so please forgive the late night clarification question. I don’t see SSO, but I do see “Cross Domain Auto Login” I assume these are the same thing. I had this enabled, but I disabled it tonight to see if makes a difference.

    Are you saying its a cost-savings balance I should consider (enable it) and am I looking at the right area in the network admin settings? Settings > Domain Mapping > Cross Domain Autologin.

    My goal is to minimize the impact on resources to try and see if what’s causing our server resources to gradually “fill up” and cause us to have to restart one or more LAMP services.

    Thanks again.

  • Ash
    • WordPress Hacker

    Hello @maxwebgear

    I hope you are well today.

    Yes, you are right. That means “Cross Domain Autologin” and it takes much more memory and it is costly.

    If you disable it the loading time should be decreased. Though for a “huge” network, that loading time should not be a concern in most cases. But yes, it depends on you.

    My goal is to minimize the impact on resources to try and see if what’s causing our server resources to gradually “fill up” and cause us to have to restart one or more LAMP services.

    What is your OS (ubuntu or centOS or Fedora etc)?

    And how much RAM do you have?

    In some VPS, mysql crashes a lot. So you need to make sure if it is apache or mysql that forces you to restart your server.

    Cheers

    Ash

  • maxwebgear
    • The Incredible Code Injector

    We are using a dedicated managed server (Linus CentOS). They are rebooting Apache for the most part, but see a lot of services be used up in php specifically.

    It’s either the software gradually consuming resources until it crashes or time for a server upgrade. We only have about 4 gigs of RAM currently I have another one setup and ready to migrate to (8g) and considering a rackspace move that will give me 12g RAM.

    The way our team describes it to me, is they say the server is like a jar and its gradually filling up the resources. So restarting Apache “empties the jar”.

    Thanks again.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.