Domain mapping plugin and php versions

Running multisite with domain mapping. I have two setups on the same server.
I have checked DNS, .htaccess, wp-config.php and server setups everything is identical but one thing.

Domain mapping is not working properly on the setup with php 5.6.26, FPM application served by Apache.
The other site is using php 5.4.16, FPM application served by Apache seems to be working.

An insight if there are PHP version issues with Domain Mapping plugin?
thank you.