Domain Mapping Plugin Error, version of sunrise is too old.

Hi I just installed Domain mapping plugin, keep getting an error:

You use old version of /Users/robertbullen/Dropbox/Development/vhost/diysites/wp-content/sunrise.php file. Please, replace that file with new version which is located by following path: /Users/robertbullen/Dropbox/Development/vhost/diysites/wp-content/plugins/domain-mapping/sunrise.php.

Note: This is a Dev site, so can't give you access/view to check it out.

  • Robert

    Tried that, still the same error. What version of sunrise.php should I have? I've installed latest version of Domain Mapping from WPMUDEV dashboard, but no joy.

    Here's my version of sunrise.php:

    <?php
    $sunrises = array(
    	"dm_sunrise" => defined("DM_CUSTOM_SUNRISE") ? DM_CUSTOM_SUNRISE : ( defined( "WP_PLUGIN_DIR" ) ?  rtrim( WP_PLUGIN_DIR, '/\\' ) . "/domain-mapping/inc/sunrise.php" : dirname( __FILE__ ) .  "/plugins/domain-mapping/inc/sunrise.php" ),
    	"md_sunrise" => defined("MD_CUSTOM_SUNRISE") ? MD_CUSTOM_SUNRISE : ( defined( "WP_PLUGIN_DIR" ) ?  rtrim( WP_PLUGIN_DIR, '/\\' ) . "/multi-domains/inc/sunrise.php" : dirname( __FILE__ ) .  "/plugins/multi-domains/inc/sunrise.php" )
    );
    
    foreach( $sunrises as $sunrise ){
    	if( is_readable( $sunrise ) ){
    		include $sunrise;
    	}
    }

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.