Domain Mapping Plugin Features Not Appearing After Install

Hello,

I successfully installed the Domain mapping plugin 3.0.2 on two different WPMS 3.0.3 installations at GoDaddy. It works slicker than than butter!
Both sites have a variety of plugins activated and about a dozen blogs and all is happy.

http://multisitepro.net
http://blogcrop.com

I have a third WPMS 3.0.3 installation at GoDaddy and cannot get the Domain Mapping plugin to install properly even after multiple attempts. http://soobahkdo.biz

Inspecting the database reveal domain mapping tables are not being added. Other plugins are able to successfully add tables to the DB when they are activated.

Any idea why the install and table modification might fail on this installation but not the others? They are all identical.

Is there an SQL file available that I can run on the database to install the necessary tables?

Thanks for any help.
Phil Duncan

    Mason

    Hiya Phil,

    So on this third install do you have a table called wp_domain_map? It's just not populating?

    I'd have to think there is a setting somewhere that is different from the others. Have you gone back through and made sure sunrise.php is installed and commented out in the wp-config file? Does the option to set the IP address appear under Super Admin>Options?

    Thanks. Very odd, but we'll help ya get it sorted

    SooBahkDo

    The DB does not have the wp_domain table in it at all.

    The Domain Mapping option does not appear in the Admin tools panel.

    I do have sunrise installed in wp-content.
    I do have it uncommented in WP-config.
    I do have domain-mapping.php (ver 3.02) in mu-plugins.

    It appears that whatever is supposed to trigger the creation of the wp_domains table in the DB just never does so.

    I have removed and reinstalled domain mapping plugin and sunrise several times and even tried an older version of domain mapping plugin just to see if I got any different results or errors. No change.

    Just for kicks I installed WordPress MU Domain Mapping (ver .0.5.3) available through Wordpress.org from Donncha O Caoimh. When I activated that plugin the options appeared in the Super Admin panel and all the screens were accessible. However, I did not actually configure or test it as I prefer to use the WMMUDEV version.

    I have triple checked all the settings and compared all server settings on this install to the server settings on the other working installs and cannot seem to locate any differences.

    I am almost inclined to delete the whole install at the host and start over from scratch.

    Today I am deleting all plugins and all themes to get down to a basic install and will see if that changes things or not. If it does not and unless someone has other advice, then I will probably just delete and start over.

    It would be a disaster if I had a hundred client sites on this installation and actually as soon as it is funtioning, it will have 160+ sites activated on it with many using the domain mapping and the multi-domain features on this install.

    Any ideas or assistance is appreciated.

    Phil Duncan

    SooBahkDo

    Hello Ulrich,

    Thanks for the assist.

    I got so frustrated with that site that I deleted the entire installation and database and reinstalled.
    When I activated the domain mapping it worked like a charm, so there was something amiss that I simply could not identify.

    I have since also installed multi-domains and all remains happy.

    All three sites are chugging along now.

    Thanks for the help.
    Best wishes to all for a prosperous New Year.

    Sincerely,
    Phil Duncan