Domain Mapping Plugin locks me into login page

Hi, guys,

NOTE: The dropdown says 'multi-domains', but this is for the domain-mapping plugin. Its not installed at the moment as it locks me out of my site, so it's not available as a choice in the dropdown.

Not sure what I might have done wrong, but I'm having some sort of problem with Domain Mapping. I have a multisite installation of WordPress. I'm running both the Domain Mapping & Multi-Domain plugins on my site, and found myself unable to log in. Every time I tried, I ended back up at the login page.

After removing the Domain Mapping plugin, I was again able to log in.

Once logged in, if I replace the plugin, I have no issues with navigation at all. I've checked settings, used the sunrise.php file from the Domain Mapping plugin, and altered all of the code in the config file to match instructions.

https://premium.wpmudev.org/forums/topic/can-multi-domain-and-domain-mapping-work-at-the-time

I should note that it does not affect the front side of the site. Visitors can still navigate the website, they just can't log in.

During trouble-shooting, at one point I removed EVERY plugin except for Domain Mapping, and it still locked me out, so I'm not even sure its a plugin conflict. Maybe something I did wrong with my config file?

Any ideas?

Thanks,

  • Predrag Dubajic

    Hey @christopher_wilson,

    Hope you're doing well today :slight_smile:

    Can you tell me if you are having any additional rules in your .htaccess file that could be causing this?
    If you do, have you tried using default .htaccess rules and see if the same thing happens then?
    You can find default rules here https://codex.wordpress.org/htaccess

    Since you get locked out of admin after activating DM there's not much we can do with support access, so if .htaccess doesn't give any results could you provide us with your FTP login details which will allow us to investigate this further?

    You can send us your details using our contact form https://premium.wpmudev.org/contact/ and the template below:

    IMPORTANT: Make sure you select "I have a different question" for your topic so it doesn't go back to forums - this and the subject line ensure that it gets assigned to me.

    Subject: "Attn: Predrag Dubajic"
    - WordPress admin username
    - WordPress admin password
    - login url
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Best regards,
    Predrag

  • christopher_wilson

    There is a snippet in there that concerns me (file attached).

    Godaddy support added this bit of code it because I was running into a problem a while back with aithene.net and http://www.aithene.net acting differently:

    <IfModule mod_rewrite.c>

    RewriteEngine on

    RewriteCond %{HTTP_HOST} ^aithene\.net$ [NC]
    RewriteRule ^(.*) http://www.aithene.net/$1 [R=301,L]

    RewriteBase /
    ...

    I believe this was caused by either the URL of the main website used when initially setting up multisite (www.aithene.net) or an issue with WordPress' Domain Mapping plugin (since removed).

    I'm uncertain as to why the IfModule command wraps the entire file.

    However, after just replacing the modified htaccess file with the default version, I once again have problems. For instance:
    http://aithene.net/friends routes you to the homepage rather than the proper landing page.
    but
    http://www.aithene.net/friends takes you to the correct page.

    If there's a way to fix this problem either IN WordPress multisite, or with the domain-mapping plugin, then I'd say its probably safe to go with the default htaccess file.

  • christopher_wilson

    Hi, Predrag,

    OK. Everything I'm reading is telling me that I probably shouldn't have set up the site in multi-site with a WWW in front of it. In fact, all of the fixes to allow me to set up a site without WWW but still allows a visitor to type it in and to be directed to the correct site in multisite look like the script above, but in reverse. So, instead of looking for the URL and adding www, it looks for a www and removes it.

    I'm unsure that will actually solve the Multi Domain problem, but it looks like a fix I should try anyway.

    It looks like maybe I can use the Cloner plugin to duplicate the site and name it without the www, rewrite the htaccess file to strip out www if it is used, and then see if that doesn't fix everything. Please let me know if Cloner simply isn't the best way to handle this job. I know that doing it by hand means going into the database, changing the URLs in every file including the wp-config and a couple others, but Cloner looks like a clean solution as well.

  • christopher_wilson

    OK. Site rebuilt w/ out the www, htaccess rewritten to handle stripping out the www when added, the correct sunrise.php in place, and everything seems to be working.

    The only problem that I had (and totally my fault for not checking things out before wiping out the old site) was that the SnapShot I took today never published to Dropbox. So it took me a couple of hours to recover the site from GoDaddy's backups. :disappointed:

    I think this one, however, is closed. I'll know more tomorrow. I'm off to a school concert for my daughter and won't be able to get back to this today.

    Thanks again.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.