Domain Mapping Plugin Not mapping my domain

Hi,

I have installed the Domain Mapping Plugin on my Multisite http://www.passion-apps.com. My site is on a shared hosting and using shared IP. I have followed the WPMUDEV Plugin documentation https://premium.wpmudev.org/project/domain-mapping/ to do all the necessary setup and configuration. In the FAQ it was stated that "You only need a dedicated IP address when using A Records to map your domain."

I have purchased a new domain (www.singaporedigital.marketing) that is Addon to my hosting account. So this new Addon domain has the document root /public_html/singaporedigital.marketing and my multisite also has the same document root, i.e, /public_html/www.passion-apps.com. I read in one of the WPMUDEV support forum that this is required. Also, in view that the domain http://www.singaporedigital.marketing already have a A record pointing to the same IP address, since both sits on the same hosting account, there was nothing I can edit on the A Records. Hence, I did not subscribe for a Dedicated IP.

I have created a new blog site on my Multisite: http://www.passion-apps.com/sgmktg so that the new domain http://www.singaporedigital.marketing can be mapped to this new blog site http://www.passion-apps.com/sgmktg. However, it did not work. The message shown was "Domain name is unavailable for access......"

Also, according to the documentation in https://premium.wpmudev.org/project/domain-mapping/ it says that to map a sub domain to one of the blog site, we have to do a CNAME mapping. In the documentation, it said that the CNAME field is where it is to land, e.g. usersite.youdomain.com. Which I understand that for my case, if I want to map a subdomain to one of my blog site the CNAME would be something like http://www.passion-apps.com/sgmktg since I am using sub directory and not sub domain for my Multisite. However, in the cpanel, a sub-directory is not accepted as a CNAME. It has to be a sub domain or main domain for CNAME. So how do we map using CNAME?

Could you please advise if I am missing out anything?

  • Vaughan
    • Support/SLS MockingJay

    Hi Esther,

    If you're using an A record, then you have to use a static IP & that IP must be pointed at your multisite DocumentRoot, so that when you enter the IP in your browser, it should show your multisite homepage.

    There's no other way around that.

    The alternative, is to rather than add the domain as an add-on domain, you could park the domain instead and then you can point it at your multisite documentRoot.

    Hope this helps

  • Esther Goh Tok Mui
    • Site Builder, Child of Zeus

    Hi Vaughan,

    Thank you for your prompt reply. I removed my domain http://www.singaporedigital.marketing from the Addon and parked the domain accordingly. Then I go back to my Multisite to map the domain, it still did not work. Still the same error message. Perhaps I do not fully understand your instruction. You mention that I have to point the parked domain to the document root. It is already residing in the same document root as my Multisite. Is there some steps I am missing?

    Similarly, I created a CName subdomain and tried to do the domain mapping, I receive the same error message that the domain name is unavailable for access.

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    Can you send your details using the following contact form (select i have a different question from the dropdown.)

    https://premium.wpmudev.org/contact/

    Mark for attn: Vaughan
    Include a ref URL to this thread.

    Please include the following details;
    - Site login details (super-admin if on multisite)
    - FTP login details so I can take a look at the theme/plugin files.
    - CPanel credentials so I can look at your Domain & DNS settings.

    Thanks

  • Esther Goh Tok Mui
    • Site Builder, Child of Zeus

    Hi Vaughan,

    Thank you for your reply. I have found the problem. It is because my Multisite http://www.passion-apps.com was installed on a Addon domain in my hosting account. For the Domain Mapping to work, the Multisite Wordpress files have to sit in the root directory of main domain – public_html, e.g. the wordpress content files must be in public_html>wp-content. For my case, the files were in public_html>passion-apps.com>wp-content. Once I install the Multisite on main domain of my hosting account and parked the mapping domains, it works perfectly, even without dedicated IP and without having to edit any A records.

    Thank you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.