Domain Mapping plugin not saving

I need help with my multisite domain mapping. For some reason, Domain Mapping plugin is not saving the domain where i want the sub site to map to, it just refresh and do nothing. I also checked the database and i don't see any prefix_domain_mapping table there.

define('SUNRISE', 'on'); is placed in wp-config, sunrise.php is moved to /wp-content and DNS of domain name that i want to use is are properly configured.

What im using:
WP Version: 4.1.1
Domain Mapping plugin: 4.3.0.4
Multidomain plugin: 1.3.4.3

Any help is appreciated. Thanks.

    • Veronica J. Kirchoff
      • Flash Drive

      Hi Vaughan,

      Done enabling the support access on wpmudev plugin support setting.

      Yes. After setting up my multisite, i installed (and configured) the Domain Mapping plugin first, didn't worked. i thought the problem is my multisite setting and the domain dns so i double check them and i didnt see any issue (wp-debug is on and domain dns is pointing correctly). reinstalled the plugin but still not saving. That's the time i decided to use the plugin from Doncha and its working pretty well. I uninstalled (and remove the table created in my database) it as i prefer to use the Domain Mapping plugin because i will install other multisite plugins on the site and they might not working well or will create conflict with plugin other than from you guys. I really want to use this plugin so i hope we can get this to work. Thanks in advance!

      btw my site is http://www.starpowerhq.com/

  • Timothy Bowers
    • Chief Pigeon

    Hey there,

    Appologies for the delay, Vaughan is currently on bereavement leave at the moment. We're working through his back feed as quickly as we possibly can.

    To help expedite this, Can you please send in:

    - Mark to my attention, the subject line should contain only: ATTN: Timothy Bowers
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include admin/network access
    - Include cPanel (I will need to look at the DB so need PHPMyAdmin or similar)
    - Include FTP
    - Include any relevant URLS for your site, like domains to map, sites to map to, etc.

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    I'll take a look at the set up, and the DB.

  • Jose
    • Bruno Diaz

    Hi there Veronica,

    Hope you are doing great.

    I was debugging in your install and I found that the mbstring extension is not installed in your server.
    While this is not a default extension, it is a very common one in most distros.
    Domain mapping relies on this extension to handle encoded characters in domain names.

    You should reach your hosting company and ask them to enable the extension.

    I'll discuss this with the lead developer in order to determine if we can add a workaround for this scenarios or at least to show a notice in the admin dashboard to let the users know about the problem.

    Please let me know if you have further questions.

    Cheers,
    Jose

  • Jose
    • Bruno Diaz

    Hi again Veronica,

    Just want to let you know that the developer has added a workaround to make it work even when mbstring extension is not installed.

    The patch will be included in the next release, which should be live tomorrow if everything goes as expected.

    Cheers,
    Jose

  • Jose
    • Bruno Diaz

    Hello Jay,

    The working correctly now in your site.
    There was a corrupt install attempt, therefore the DB structure was never created (or possibly created and dropped somehow).

    You can see one of you mapped domains working here:
    http://clientmagnetizer.com/

    You should note that I modified the add-on domain configuration in cPanel. The mapped domain should point to your main site install. (see attached image).

    Please let me know if everything works as expected.

    Cheers,
    Jose

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.