Domain Mapping plugin - when I click map domain, nothing happens.

Installed the plugin, moved the sunrise.php file to the appropriate folder.

Now I'm trying to actually map a domain to a WP subdomain instance.

My wp install is a multisite, subdomain setup running on a dedicated server.

When I try to map example.com to sub.domain.com I click the Map Domain button, the page refreshes, but nothing actually changes.

  • Michael Bissett
    • Recruit

    Hey @Kevin, hope you're doing well today! :slight_smile:

    Just to start out with the basics, have you already confirmed that a conflict isn't taking place here? If not, I'd recommend trying that, we've got a handy troubleshooting flowchart that you can use here:

    https://premium.wpmudev.org/manuals/getting-support/

    If that doesn't turn up anything, could you enable Support Access, so that we could have a closer look at things here?

    Please advise,
    Michael

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi Kevin, as per our chat and our tests, we're unable to track down the reason Domain Mapping is hanging on you, rather than mapping the domain.

    To recap:

    1. I can replicate on your site, but not my own.
    2. We've tried deactivating security and caching plugins.
    3. You went through the support flowchart to rule out another plugin or theme conflict.
    4. I checked and doublechecked your settings and they all look right.
    5. We made great Star Trek puns, because we're cool.

    Flagging second level to see if there's some insight we're both missing here, Kevin. : )

  • Kevin
    • Flash Drive

    Ok - well I found a workaround.

    Apparently the frontend button "Map Domain" doesn't work.

    So I just manually entered the records into my SQL database and it shows up and works fine.

    Maybe this will help others with this issue, because quite frankly, I didn't receive ANY help from "second level" support.

    I also won't mark this as resolved even though I found a workaround. The problem still exists.

  • whetstone_digital
    • New Recruit

    I too have the same issue. When clicking "map domain" nothing happens and the domains is not mapped.

    Strangely enough, I have other pages already installed and mapped that were not an issue, but when I tried mapping a new site now the page refreshes but nothing happens.

    Additionally when going to Network Adming > Settings > Domain Mapping the suggested IP address in the blue box is not my correct IP of the server.

    Suggestions?

    I will try Kevin's workaround in the meantime.

  • Timothy
    • Chief Pigeon

    Hey Kevin,

    24hrs has long since passed.

    Yes, Michelle never said second level support would take 24 hours, she said it would take longer. Second Level Support deal with more involved and complex issues generally, these are naturally more time consuming too.

    Can you please share the domain you're trying to map, and the main domain of the site along with your dedicated IP address?

    Has this ever worked, and if so when did it stop?

    Once these are answered can you please send in:

    - Mark to my attention, the subject line should contain only: ATTN: Timothy Bowers
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include admin/network access
    - Include cPanel (I will need to look at the DB so need PHPMyAdmin or similar)
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    I'll take a closer look.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.