Domain mapping problem. I set up everything pretty

Hi guys,

Domain mapping problem.

I set up everything pretty straight, followed the guide and stuck in the end of actually mapping domain.

I've purchased domain at site, and i hardly found those DNS records there. After i did, i set up one of my blogs to be mapped to this domain i purchased. Of course not working, getting this error:

Warning: preg_split(): No ending delimiter ',' found in /home/voxadmin/public_html/wp-content/plugins/domain-mapping/classes/class.domainmap.php on line 667

Warning: Invalid argument supplied for foreach() in /home/voxadmin/public_html/wp-content/plugins/domain-mapping/classes/class.domainmap.php on line 668

Which @Patrick in live chat explained to me. I have multiple CNAME's, and plugin does not support that.

However, now i have no clue what to do. I found those CNAME's and this is how it looks like, still have no idea how to fill those records. Here is a screenshot.

  • Vinod Dalvi

    Hi Eldin,

    Sorry to hear of the problem you are having.

    The error log messages that you have shared are simple PHP warnings and most of the time it doesn't affect functionality of site so it is nothing to worry about!

    Do you have WP_DEBUG set to true in your wp-config.php file?

    If you do then please set it to false.
    This will hide the warning messages and you will be able to use your site normally.

    Would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    Regarding multiple CNAME's, this will certainly take a bit of trial and error to resolve it.

    Therefore in an effort of expediency i have notified my colleague @Patrick about this who can better help you in this case. He will reply here ASAP.

    Vinod Dalvi

  • Patrick

    Hey there @Eldin

    I hope you're well today!

    Great that you found the DNS editor there! The CNAME records look just fine (1 for the www subdomain & 1 for FTP is a standard configuration).

    However, the IP address in the AREC entry does not appear to have been edited. It must be edited so it is the IP address of your multisite install.

    Also, I recall you mentioning in Live Support that you're using CloudFlare. In that case, one of the plugin settings is important: be sure to set Verify domain's DNS settings to No in Network Settings > Domain Mapping > Mapping Options

    Please let us know if this helps, and don't hesitate to post again if you need to.

  • Voxxyz

    Hi @Vinod and @Patrick :grinning: Thanks guys for reply and answers.

    Vinod, I did set WP DEBUG to False in wp-config.php file, Patrick told me that on live chat, still seeing error messages.

    Also i did grant access immediately after your answer but couldn't answer cause i was on mobile :slight_smile: Access is Granted :slight_smile: Feel free to enter and look around. ( I have to say i did remove domain for mapping, but i will set it up right now again).

    @Patrick hi :grinning:

    I did what you told me, sent them a pretty harsh ticket about editing CNAME records and it turns out there is a link but it's hidden in the bottom of the page (screen shot above). However i did logically edit that AREC record in other domain just to see if that works, and still nothing.

    Yes im using CloudFlare, and yes, DNS settings are set to No from the beginning: (

    Now im gonna add this other domain with these AREC settings to see how that works out. Access is Granted, feel free to look around :slight_smile:

  • Ash

    Hello @Eldin

    I hope you are well today.

    What is your subsite you want map? And what is your mapped domain?

    Let me give you a concept about this :slight_smile:

    For example, your main site is
    You have two subsites:
    These two subsites you want to map with following domains repectively:

    So, if anyone enter in the browser, it should show the site of Same for

    So, there are two scenarios now. Either you own all the domains, or you don't. First I think you own all the domains. site is hosted in a hosting whose nameservers are:

    So, you have entered these nameservers for domain panel. You have to set same nameservers for and domains too.

    Then you will add and domains as add on domain in the same hosting of, and make sure you point them to the wordpress root folder. So that if any one enter or it shows site.

    After that, you will add the domains in corresponding subsites using domain panel plugin, and the mapped domain will start working.

    Now, if you don't own the domains, then you will need a dedicated IP. I know you won't have access to the domain panel of your customers so that you can't set name servers in there. So, you will pass them your IP and they need to set a DNS record for their domain and point to that IP. Only then domain panel will work. Note that, the IP must be pointed to main site :slight_smile:

    Hope it helps :slight_smile: Please feel free to ask more question if you have.


  • Voxxyz

    Hello @Ashok and thanks for extended reply, i appreciate it.

    First, after few days (time im searching for solution) i can definetely say i can teach this domain mapping. I've watch ove 50 videos about this and trust me im aware of every single thing that can go wrong, but still im having issues i have no idea how to resolve it.

    Second: I completely understand what you are saying but that doesn't work, but let me start from the beginning, because im ovbiously missing something:

    1. Downloaded plugin, installed it.
    2. Moved sunrise.php into wp-content folder
    3. Edited wp-config.php insterted line of code "define( 'SUNRISE', 'on' );" and set debug to false - Screen shot - (
    4. After network enabling domain mapping i could see my IP server adresses (2 of them), I did copy them in the field below (both IP adresses).
    5. Went to my user site: and find domain mapping in settings, and added domain which i already bought at web site.
    6. First there was an error which i posted in threads above (php line 667 and 668), and in "health" section there was a message "invalid".
    7. Figure out somethings wrong and went to web site, found those A Records which i also posted in thread above (second image). Haven't touch anything just put in AREC field my server IP adress. (And yes im having dedicated IP adress).
    8. Problem still countinues. Invalid error and php error, but domain is "redirected" because i see the message of CloudFlare where says Error 1001 (dns problems).
    9. I've stopped for a while then i purchased another domain at another domain selling website - Namecheap. Try to set up A records, couldn't (again some kind an error, which i honestly didn't even look, just turn off the web site i went to sleep).
    10. I got a friend who's working with me and his duties are about our servers ( i call him server guy in other threads), he's an expert for domains and server things. He also couldn't set up simple hosting in this web site, so i thought that might be problems at their place, so i sent them a ticket and got random message where young lady explains to me how to set up those thing, which i already knew.)
    11. Now few things bothers me: 1. Health status - invalid? is that ok? and 2. Debug message is still showing after i set up debug to false.

    I really have no idea what am i doing wrong, am i missing something or..

  • Voxxyz


    I said i did miss something and i sure did.

    In the settings of domain mapping i just copy these (server IP) adresses in field below and these are not correct. Have no idea how, but these adresses what domain mapping automatically suggested to me are NOT the Server IP adresses. Here is a screen shot, and this is resolved! (Finally)

    Really appologise for bothering you guys, but i knew i made mistake somewhere and i found it.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.