Domain Mapping Redirect issue

When Domain Mapping plugin is enabled the dashboard isn't loading, and is redirecting, and giving the following message:
This page isn’t working .redirected you too many times.

Please advise what needs to be done to fix this.

  • Adam Czajczyk
    • Support Gorilla

    Hi Lendon

    I hope you're well today and thank you for your question!

    I think that's a bit more complex case because Flywheel is a managed hosting and requires slightly different treatment and there's also CloudFlare involved. Let me try to break it down then.

    Assuming that you have a dedicated IP (and each site on Flywheel comes with its own IP so you get one) the procedure would be pretty much as Nithin described during the chat:

    1. Set "domaintobemapped.com" A record to point to that IP
    2. Wait until DNS propagates (that might be fast but might also take up to 24-72 hours!)
    3. Having "Domain Mapping" plugin enabled, go to the "Tools -> Domain Mapping" in a sub-site dashboard and add the domain there.

    However, there's a CloudFlare and SSL involved. I checked one of the domains "thereef...com" and when put in a browser it redirects to the main "pcb..com" site. That's a 301 Moved Permanently redirect which shouldn't be there. I'm not sure, unfortunately, how that's currently set up but there should be no redirect of that kind.

    The way it should be set up would be:

    1. skip the CloudFlare (like you were never using it) and add the domain to your "pcb...com" site in Flywheel first:

    https://getflywheel.com/wordpress-support/can-i-point-multiple-domains-at-my-website/

    Don't set it as primary but it should after that be loading the "pcb...com" site without redirects, don't worry if the site appears "broken" as long as it loads.

    2. Once this is working, then you can actually include CloudFlare to this by simply going to CloudFlare panel and following the "wizard" there: it would only ask you to put the domain name there, would scan the configuration and then would give you two nameservers that you will have to set in the domain DNS - at domain registrar. Please note, before conducting step 1 and 2 that "domaintobemapped" should have the DNS "reset" to default registrar setup.

    This should redirect the domain properly through CloudFlare but since the site is available over SSL there's additional step to take care of, see below.

    3. From outside - since the site is behind CloudFlare - I can only see the CloudFlare SSL certificate. Flywheel-hosted sites can now also use free certificates (https://getflywheel.com/why-flywheel/simple-ssl/) and I don't know if you do use it/them or now.

    If "without CloudFlare" the site is not protected by SSL, you will want to go to the SSL settings in CloudFlare and make sure that it's set to "flexible" (should work in most cases). But if you also do have certificate directly on Flywheel, that should be set in CloudFlare to "Strict" I believe, otherwise there'll be redirect errors.

    4. Only after that, once it's sorted, you should be able to map the domain by going to the "Tools -> Domain Mapping" page in the sub-site of your site and adding domain there.

    When adding mapping, you should also make sure that the "https" protocol is selected for mapped domain.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.