Domain Mapping -> redirecting to registration page. Help!

I installed the domain mapping according to instructions but I have a problem when I try to access the mapping domain or even the subdomain original, after I have mapped the domain - now when I try to access the blog through either of these directions, I am sent to the registration page and given the following information:

http://citylogica.com/wp-signup.php?new=mercedguide.com

>>>>
Greetings Site Administrator! You are currently allowing 'none' registrations. To change or disable registration go to your Options page.

Spam is a huge problem on the Internet. Protect your site by using WP-Hashcash, Cookies For Comments or follow this advice. They should help stop or slow down those who create spam blogs on your site.
>>>>>

Note - when I delete the mapping for this blog's URL, I can once again access the blog via the subdomain (merced.citylogica.com).

Also, if I just remove domain mapping tool and specify the domain in the blog edit > site URL fields, it will also work to access it via the domain. In otherwords, access to the blog should technically work via subdomain *or* URL. But with the domain-mapping tool in place and the mapping in place, both stop working.

One thought - when I go to the admin options I notice the option for Support Only default to "yes" and even when I attempt to change it to "no" and submit... it still comes back as "yes". Perhaps this is related?

Any insights are appreciated.

Thanks!

  • Barry
    • DEV MAN’s Mascot

    Can you check that the table is created in your database, and either in phpMyAdmin, or in the domain mapping page (under tools) check that the mapped domain remains set:

    e.g. set the domain, go to another page and return. Is it still there?

    Also, can you double check that you added the sunrise.php file in the correct place (wp-content) and that you have enabled use of the sunrise file within your wp-config.php file.

    Thanks

  • citylogic
    • WPMU DEV Initiate

    Do you know which dB table to look at ? I'm not even sure where to start. There are some 50 odd tables here right now (I have 10 blogs setup).

    Do you mean this line in the //wp-content/sunrise.php file? Did that. I uncommented this line:
    define( 'DOMAIN_MAPPING', 1 );

  • citylogic
    • WPMU DEV Initiate

    Hmm - you know I *thought* that is probably where the value should be but ... two problems:

    1. That value does not exist in this table
    2. the meta_value field seems uneditable. Through the tool I'm using, all the fields simply say (MEMO). Never seen that before.

    The fact that this value isn't in the dB must indicate some other dependent piece of code is missing I'm guessing? Something else I should have installed perhaps? Or do I simply need to figure out how to insert that value in the dB ?

  • citylogic
    • WPMU DEV Initiate

    I just attempted inserting a record into the wp_sitemeta table, via PHP MyAdmin.

    Basically:
    insert into wp_sitemeta set site_id=1, meta_id=243, meta_key='map_supporteronly', meta_value='0

    ...this did nothing to solve either of the problems:

    1. still cannot access the blogs via domain name or subdomain after doing the mapping via this domain mapping plugin
    2. Still supportrs_only dropdown in the options tab defaults to "yes".

    About to give up on this darn plugin. This is getting quite frustrating. :slight_frown:

    Thoughts?

  • citylogic
    • WPMU DEV Initiate

    Ah, but when I tried to update server IP address, it did not update. So I must have set that value somewhere else. So basically both options under the Domain mapping section are NOT working.

    Question - what we're trying to do it reset the option that says domain mapping is only for supporters .. I'm assuming that will fix my problem. Am I correct? Are we chasing the bird, so to speak? Or are these unrelated issues?

    Thanks.

  • citylogic
    • WPMU DEV Initiate

    Ok - some new information:

    I have another site that i successfully setup with wpmu and domain mapping a few months ago. So I copied the entire mu-plugins directory from there and replaced it on my citylogica site which is having this problem. A couple interesting things happened:

    #1 - that supporters only option that's not working ... went away! The interface no longer gives that option!

    #2 Now when I try to access one of the mapped domains, it still gives the same registration page ... *UNLESS* I delete the mapping and recreate it. If I so that, its still not working to map correctly ... but this time it will send me to the /wp-admin/ dashboard page if I'm logged in, or if not, it will redirect me to here:

    http://citylogica.com/wp-login.php?redirect_to=http%3A%2F%2Fcitylogica.com%2Fwp-admin%2F

    Seeing any clues yet? :-\

  • citylogic
    • WPMU DEV Initiate

    Ok - I seem to have resolved the issue. I don't understand why ... but I deleted the wp_domain_map and wp_domain_mapping tables and re-mapped the blogs from scratch and that seemed to do the trick.

    My guess is the issue is related to me starting with the older version of domain mapping plugin and then upgrading it. I assume there's some issue with both wp_domain_map and wp_domain_mapping tables existing in the dB.

    Hope this helps explain it for the next person who has this issue...

  • marshalltech
    • WPMU DEV Initiate

    citylogic,

    Thanks so much for posting this. I was looking all over for a solution. I simply uninstalled/deleted the plugin, re-installed it manually (not through WPMU Dev dashboard) and everything started to work fine. I think you're right...may have something to do with upgrading it.

    Thanks again...I was the "next person" who this was very helpful to (2 years later). :slight_smile:

  • John
    • New Recruit

    I encountered this same issue, and discovered that by selecting "network deactivate" for the MU domain plugin, and then activating the plugin on the primary site, the settings still appear on the network dashboard. From there, I was able to add my domains. I did NOT have to enable the plugin on any of the other sites.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.