Domain Mapping Setup

I've completed instruction number 1 below but I don't know how to completed instruction 2 & 3. Can you assist? Any help would be greatly appreciated.

1) Please copy the sunrise.php from your plugin folder /home/ichedo/public_html/wp-content/plugins/domain-mapping/sunrise.php into /home/ichedo/public_html/wp-content/sunrise.php. (Completed)

2) In your /home/ichedo/public_html/wp-config.php file please uncomment or add (if not available) the following code: define( 'SUNRISE', 'on' )

3) If you've not already added define('SUNRISE', 'on'); then please do so. If you added the constant be sure to uncomment this line: //define('SUNRISE', 'on'); in the wp-config.php file.
------------------------------------------------------------------------------------------------------------------------------

  • Tyler Postle

    Hey Nicholas,

    You will need to use either FTP or the "File Manager" within your cPanel and then find the wp-config.php file within the root of your WP install.

    Open that up and first check if this line exists:

    // define('SUNRISE', 'on');

    If so, change it to:

    define('SUNRISE', 'on');

    That just uncomments it so it will be executed.

    If no "SUNRISE" constant exists then just paste in this:

    define('SUNRISE', 'on');

    Right above this line:

    /* That's all, stop editing! Happy blogging. */

    If you're still unsure then could you send in your FTP? Then we can do this for you :slight_smile:

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    Talk to you soon!

    Cheers,
    Tyler

  • Nicholas

    Ok. So I was able to make the edits. I'm trying to map a subsite (Piwaiofficial@ichedo.com) to a new domain i recently purchased from Godaddy (www.piwaiofficial.com). I've entered the domain in the configuration and clicked the "Map Domain" button but I get the error in the image below. I'm assuming that I need to do something on Godaddy's side to fix this but I don't know exactly what. Can you advise?
    [image pos="0"]

  • Nicholas

    I tried to attached the image but it seems that its not attaching. the error says "Domain name is unavailable to access". We can't access your new domain. Mapping a new domain can take as little as 15 minutes to resolve but in some cases can take up to 72 hour so please wait if you just bought it. If it is an existing domain and has already been fully propagated, check your DNS records are configured correctly." My question is, what exactly so I need to configure in my DNS?

  • Tyler Postle

    Awesome, yes so for this next error you are seeing first we need to figure out whether you have a dedicated IP address or not?

    It looks like you don't, so best option is to point your new domains name servers to your web host.

    I'm not sure what GoDaddy's interface is like, but somewhere you should have fields with these name servers in them:

    NS57.DOMAINCONTROL.COM
    NS58.DOMAINCONTROL.COM

    Change those to this:

    NS1.ICHEDO.COM
    NS2.ICHEDO.COM

    Then in your cPanel for your web host, go to your Parked Domains:

    and add the domain then point it to the root of your WP install.

    Your WP root might not be /public_html - although they usually are but if not then change it to whatever yours is.

    The domain will need to propagate to your new name servers so that may take a bit of time.

    Let me know if you're still having issues after that :slight_smile:

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.