Domain Mapping Single Sign-on SSL

Problem:

When single sign-on is enabled and access is via HTTPS some items are insecure resulting in browsers warnings, or worse. Verified in admin section.

Cause:

Around line 243 of domain-mapping.php $url is set. Hard coded to HTTP only.

This URL is then used to render the stylesheet_for_cookie.

This is particularly problematic when using WP core config FORCE_SSL_ADMIN or FORCE_SSL_LOGIN.

A similar problem exists in multi-domains plugin too as it uses the same technique ($url is set around line 1123 of multi-domains.php).

  • aecnu
    • WP Unicorn

    Greetings rjoc,

    Thank you for your feedback and input regarding the Domain Mapping and Multi Domains plugin SSL issue and thank you for pointing out the probable source of the issues.

    I only say probable because I am not the lead developer of this plugin and therefore I am not qualified to make that determination.

    However, I will alert the lead developer of this issue and hopefully he will share his invaluable insight into this plugin and address the same.

    Though this may take longer then a normal ticket, I will try to get him in here asap.

    Thank you for being a WPMU Dev Member!

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Robert,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.