Domain Mapping, SSL and WP Engine

Hello, i would like to know how i should configure the settings for the WPMUDEV Domain Mapping plugin in order to have an SSL Certificate for the mapped domain on WP Engine.
According to WP Engine the only domain mapping plugin they recommend is the "automattic" one ...
But i would like to use your plugin because of its integration with Pro Sites...

I have a SSL setup for my main site, working fina, without issues, another one for a subdomain (no domain mapped to it) ...

But when i try to set a ssl for a domain name that is mapped to a subsite, i get redirect loops...

Do i have to have a ssl certificate for the subdomain to which i will map the domain name to?
example:

turn http://subdomain.maindomain.com to https://subdomain.maindomain.com befor mapping it to https://mappeddomain.com

What settings do you recommend for the plugin under wp-admin network settings domainmapping ?

Thanks in advance...
Sorry for the long explanation

  • Rupok

    Hi lopesV,

    You don't need to be sorry for the long description. Rather detailed descriptions help us understand the requirement better. Thanks for sending details.

    i would like to know how i should configure the settings for the WPMUDEV Domain Mapping plugin in order to have an SSL Certificate for the mapped domain on WP Engine

    I don't think you will need to do anything different in Domain Mapping settings for WP Engine.

    According to WP Engine the only domain mapping plugin they recommend is the "automattic" one

    Maybe they recommend the automattic one, but that doesn't mean you *have to* use that one. In my personal opinion, our Domain Mapping plugin is more awesome. And our Domain Mapping plugin should work without any issue in WP Engine server.

    Do i have to have a ssl certificate for the subdomain to which i will map the domain name to?

    No, you don't have to have SSL Certificate for the subdomains but in that case, when you map a domain, you should select "Directed to mapped (primary) domain" option from the "Front end redirect should be:" option. Please check the attached screenshot for reference.

    And when you map a domain, you should use "HTTPS" protocol while adding that domain. And above everything, you should have SSL certificate installed in the server for the domain you are mapping to the subsite (e.g. mappeddomain.com).

    What settings do you recommend for the plugin under wp-admin network settings domainmapping ?

    I'd recommend having "Yes" for "Would you like to force https in login and admin pages:" option and "Force HTTPS" for "Would you like to force http/https in front-end pages:" option. Please check the attached screenshot for reference.

    But when i try to set a ssl for a domain name that is mapped to a subsite, i get redirect loops...

    Can you please confirm that you have set "Directed to mapped (primary) domain" selected, and HTTPS forced in the way I described above and still getting redirect loop? In that case, I'll need to check your full configuration. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • lopesV

    Hi kasia is my htaccess:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    php_value max_input_vars 10000

    My SSL for this domain is setup with :
    Allow non-SSL configured pages to use https://

    And:
    Use https:// for WP-Login (enabled)
    Use https:// for WP-Admin (enabled)

    The certificate is provided by WP Engine, and those are the only settings it provides,
    There is another certificate for my main domain of the multisite that is working just fine.

  • Nithin

    Hi lopesV,

    Hope you are doing good today. :slight_smile:

    I checked your website, and made some changes like force https under Settings > Domain mapping, and then re-mapped your domain.

    It seems like now the redirect loops are gone, and your website seems to work fine. Could you please clear your browser cookies, and cache and check whether it works fine.

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi lopesV,

    So for the Domain Mapping Setting: "administration mapping" you dont recommend me using "mapped domain"? Do i have to leave it on " domain entered by the user" to avoid issues?

    It seems like while testing, I had to go through your subsite dashboard, and forgot to switch that to mapped domain, sorry about that. It should work fine with mapped domain, please switch it back to mapped domain.

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.