Domain Mapping: SSL issue for sub site

Hi there

I am running multiSite on https://thepromogroup.co.za. I have a subfolder site called https://thepromogroup.co.za/pointpromo. I have mapped it to http://pointpromo.co.za (no SSL).

However it keeps forcing https://pointpromo.co.za and then a SSL warning comes up.

How do I allow it to go to http://pointpromo.co.za?

Regards

Dane

  • Dimitris
    • Support Star

    Hey there Dane,

    hope you're doing good and thanks for reaching us! :slight_smile:

    There are some complaints about redirects of this type and there are some current development in Domain Mapping plugin which hopefully will resolve these.

    Have you tried to force the http:// protocol of mapped domain?
    You should be able to switch between protocols using the little key icon in mapped domain tab (either in network admin are or subsite settings of DM)

    This also relies on the way you force the https:// protocol though.
    Is this via Domain Mapping setting?

    Or via another plugin maybe?
    Any .htaccess rules, custom or coming through plugin? If so, could you please share these in next reply?

    Then, when I navigate to http://pointpromo.co.za/, I don't get the WP subsite but another folder of server with an indexOLD.html file instead.
    Could you please double check that the DocumentRoot of the mapped domain is pointing to the exact same directory as the main WP multisite?
    Reference: https://premium.wpmudev.org/project/domain-mapping/#product-usage

    Finally, please consider granting us with temporary support access to your website to have a better look of its setup. You can do so via WPMUDEV Dashboard plugin as described here (no need to share credentials): https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Warm regards,
    Dimitris

  • Dane
    • New Recruit

    Hi Dimitris

    I'm not sure what is going on but I have removed the domain so that I could re map it, but now I can't find the domains section. I tried going to the URL but got this (see attachment).

    I have made the other changes to not force HTTPS.

    I have given you access to the website.

    Regards

    Dane

  • Dimitris
    • Support Star

    Hey there Dane,

    I was able to access DM settings page in network admin area
    /wp-admin/network/settings.php?page=domainmapping_options

    Could you please try to clear your browser's cache as described here
    http://www.refreshyourcache.com/en/home/
    and try to login once more?

    Also, please ensure that the DocumentRoot of the mapped domain is pointing to the exact same directory as the main WP multisite, after adding it as an add-on domain.
    Reference: https://premium.wpmudev.org/project/domain-mapping/#product-usage

    and inform us on this:

    This also relies on the way you force the https:// protocol though.

    Warm regards,
    Dimitris :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.