Domain Mapping & SSL Issues on MU

Hi,

I have bought a multidomain SSL certificate and successfully installed on my VestaCP VPS.

I have a wordpress multisite installation with 5 sites currently. I have been trying to force HTTPS with Domain Mapping plugin. I have also installed the "SSL Insecure Content Fixer" in order not to have mixed content over HTTP.

I have activated in the domain mapping plugin the following:

1. After activating that, some webs doesn't load the HTTPS securely, even having the SSL Insecure Content Fixer.

2. Also, some webs are having problems, while others not: .

3. And also, my subsites, are not loading in the frontend the pages in HTTPS… What must I do?

Please note: I am running my sites over Cloudflare, I don't know if it matters or not…

  • Dimitris
    • Support Star

    Hey there Pol Ribas,

    hope you're doing good and thanks for reaching us! :slight_smile:

    Could you please double check that the site address if your subsites are indeed using the https:// protocol. Simply go to network admin area under Sites and edit subsite settings.

    (my screenshot is made from a subfolder multisite instead)

    It seems that there are still mixed-content errors in your backend pages. :thinking:

    I most of the times use the Really Simple SSL plugin for that and I haven't experieced any issues like that. Could you please give this a try and test again?

    If this errors continues, please consider granting support access to your website so we could better inspect it. You can do so via WPMUDEV Dashboard plugin, no need to share credentials.

    Here's a quick guide on how to do so

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Just let us know here in your next reply that you've granted us access as we don't get any kind of notification.

    Finally, as I see you're in trial period with us, so this link may contain some more useful info for you

    https://premium.wpmudev.org/docs/getting-started/how-free-trials-work/

    Warm regards,

    Dimitris

  • polribas14
    • Design Lord, Child of Thor

    Hi Dimitris ,

    Thanks for your quick reply!

    Either when I use the plugin you recommended me (Really Simple SSL) or manually put the HTTPS on the site adress (I hadn't try it until now that you've said it to me), the back end wp-admin of all sites work correctly, but the front end sites are returning that:

    And forcing with the domain mapping plugin, the subsites front end are not forced… I can force page per page manually… but that's not what I want… I want it automatically.

    Maybe is because of the cloudflare CDN?

    I have skipped the trial and I have granted access to my websites, so you can see what is happening. Thanks!!!

  • polribas14
    • Design Lord, Child of Thor

    Hi,

    Thanks for your quick reply!

    Either when I use the plugin you recommended me (Really Simple SSL) or manually put the HTTPS on the site adress (I hadn’t try it until now that you’ve said it to me), the back end wp-admin of all sites work correctly, but the front end sites are returning that:

    And forcing with the domain mapping plugin, the subsites front end are not forced… I can force page per page manually… but that’s not what I want… I want it automatically.

    Maybe is because of the cloudflare CDN?

    I have skipped the trial and I have granted access to my websites, so you can see what is happening. Thanks!!!

  • Adam Czajczyk
    • Support Gorilla

    Hello polribas14!

    I have checked your site and I see that currently the domains are added to the WordPress directly. They are protected with CloudFlare SSL which should be perfectly fine and actually the main site (especializados.es) load well both over http and https://.

    However:

    1. In case of other site if a connection goes over https:// there is a mixed content delivered.

    2. You mentioned in your initial post that you have purchased and implement a certificate but a check of your site says that the certificate that’s protecting the site is form CloudFlare.

    That being said could you please disable CloudFlare for the site entirely for now and then make sure again that the support access is granted. I would then access the site again and I would be able to check it again without any glitches and misrepresentations that may be coming from CloudFlare proxing the site.

    If we make it work fine without CloudFlare we may then get back to CloudFlare and focus on its configuration.

    Let me know when it’s disabled please.

    Kind regards,

    Adam

  • polribas14
    • Design Lord, Child of Thor

    Hi Adam, it’s now disabled, thanks! I am getting infinite redirects on some of my subsites:

    – gadgetgt.com: redirect only front end

    – grupoespcializados.com: redirect back&front end

    – picaronia.com: redirect front end only

    – intranet.grupoespcializados.com: redirect back&front end

    Thanks!

  • Dimitris
    • Support Star

    Hey there polribas14,

    hope you’re doing good and please excuse our late reply here! :slight_smile:

    I accessed your installation and noticed that all of your sites are working (both in backend and frontend pages) without using any https protocol.

    As I can see in Sites /wp-admin/network/sites.php

    all of these are still using a http:// protocol in their site address.

    If you want to use the multi-domain SSL certificate you mentioned, could you please try to change your subsites to https:// as described in my initial reply here:

    https://premium.wpmudev.org/forums/topic/domain-mapping-ssl-issues-on-mu#post-1210694

    For changing the protocol of the main domain though, you should follow the steps just like changing domain name.You can use the steps provided here

    https://wpengine.com/support/how-to-change-a-multi-site-primary-domain/

    For all DB changes, you may also use the famous “Database Search and Replace Script in PHP” instead.

    After doing so, the “force https” settings in Domain Mapping won’t have to do much, so you could leave them to “do not”. The Really Simple SSL plugin should be able to surpass any mixed-content errors then.

    Warm regards,

    Dimitris

  • Dimitris
    • Support Star

    Hey there polribas14,

    hope you’re doing good! :slight_smile:

    I’m really sorry for the frustration here, could you please send us some server details in order to have a better look inside? As this is public forum, you should send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: “Attn: Dimitris

    – WordPress admin (login url/username/password)

    – FTP credentials (host/username/password)

    – cPanel/Plesk credentials (host/username/password)

    – link back to this thread for reference

    – any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Finally, as this is a network with live traffic, please let me know in your message a low-traffic time period and your local timezone so I can try to dig in during this.

    Warm regards,

    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.