Domain Mapping -> SubDomain stop working... redirects to domain.

Hi, I have installed the "Domain Mapping" plugin to allow the use of domain names.

Now my subdomain redirects to the domain. I don't want this behaviour. I would like the subdomain to continue working as subdomain but the domain also to work.

The reason is that sometimes if the domain is not yet registered it is not possible to view the website. While building it.

Could you send a suggestion how to change this?

Thanks

Flav

  • Ash

    Hello @Flaviano

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    Please go to Network Admin > Settings > Domain Mapping > Select "domain entered by the user" for administration and login mapping.

    Then go to subsite Dashboard > Tools > Domain Mapping > remove the added domain. And then add the domain and add again. When you will add again, select "disabled and entered domain should be used" for Front end redirect should be.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers
    Ash

    • Flaviano

      Hi Ash, thank you for your quick reply.

      That works but I was looking for an automated solution. At the moment I have the websites being provisioned by WHMCS MU Provisioning plugin. So I would like the system to create the subsite automatically with the desired option, any indications on how to force this change on signup?

      The reason I want to do this is because sometimes a domain is not yet registered or pointing to our servers and I would like the users to be able to preview the subsite immediately after signing up.

      Thanks

      Flav

  • Flaviano

    Hi Ash, thank you for your quick reply.

    That works but I was looking for an automated solution. At the moment I have the websites being provisioned by WHMCS MU Provisioning plugin. So I would like the system to create the subsite automatically with the desired option, any indications on how to force this change on signup?

    The reason I want to do this is because sometimes a domain is not yet registered or pointing to our servers and I would like the users to be able to preview the subsite immediately after signing up.

    Thanks

    Flav

  • Ash

    Hello @Flaviano

    There is no automated solution, I am afraid. If the domain is not propagated, then they won't reach your multisite server, and if they don't reach your multisite server they can't be redirected to the subsite or anywhere.

    So, currently you can select "disabled and entered domain should be used" for Front end redirect should be, so that domain and subsite url both works.

    Cheers
    Ash

    • Flaviano

      Hello Ash, sorry I think there is a misunderstanding, maybe I didn't explain properly.

      The current stages are:

      1) User gets a package in WHMCS
      2) The subsite is provisioned in wordpress automatically (using your WHMCS plugin)
      3) The domain is mapped automatically in wordpress
      4) Users login to wordpress and click "view site"
      5) The system redirects the "subdomain url" to the "domain url".

      We only need a solution for the "Step 5". We don't want the website to be redirected to the domain.

      You have mentioned that we can "add and remove" the domain and select "disabled and entered domain should be used", but we don't want this to be done manually, we want it to be set automatically.

      Thanks.

      Flav

  • Flaviano

    Hello Ash, sorry I think there is a misunderstanding, maybe I didn't explain properly.

    The current stages are:

    1) User gets a package in WHMCS
    2) The subsite is provisioned in wordpress automatically (using your WHMCS plugin)
    3) The domain is mapped automatically in wordpress
    4) Users login to wordpress and click "view site"
    5) The system redirects the "subdomain url" to the "domain url".

    We only need a solution for the "Step 5". We don't want the website to be redirected to the domain.

    You have mentioned that we can "add and remove" the domain and select "disabled and entered domain should be used", but we don't want this to be done manually, we want it to be set automatically.

    Thanks.

    Flav

  • wp.network

    @Flaviano some kind of feature that auto-delays the 'step 5' mapping until DNS Verification passes would be sweet indeed (and would get my +1)!

    I'd love to know if you manage to come up with a work around :slight_smile:

    Cheers, Max

    ps. keep in mind, you may also need to make sure somehow that the original network address doesn't get indexed prior to the mapping (and, hopefully, full URL canonicalization) - or at least that you afterwards make sure the original resource addresses are 301 to the mapped addresses since it is not unlike a domain migration from Gbot's standpoint :slight_smile:

  • Ash

    Hello @Flaviano

    I have talked to the developer about this issue. It will need a fair amount of custom code I am afraid. You have to customize the plugin to achieve so.

    Also, if you need to customise this then you can post a job in our job board where you can hire a developer to assist further: https://premium.wpmudev.org/wpmu-jobs/ Please note that, no WPMU official staffs are allowed to work in the job board.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.