Domain Mapping un sure how to map a domain

Not sure what I am doing ... lol
I want to map a domain to my multi site but im not keen enough to know what to do with pointers, subdirectories, or parking... not sure what to do...
Its set up like Fullenenterpries.com/site1 (where i would like to point my domain bryanfullen.com to the subdirectory, and it show byranfullen.com but i see no mapped domains in the plugin so i figured i need to go to c panel in ipage and point ...park... or add to subdirectory which do i do? thanks

  • James Morris

    Hello Bryan,

    I hope you are well today.

    How this is accomplished will vary a little bit depending on whether you are hosted on a dedicated server/VPS or a shared hosting account. For instance, the steps are a little different if you have a static IP address.

    However, commonly, members set this up using a shared cPanel account using Add-on domains. I've put together the following video walk-thru that illustrates the process.

    Video: https://goo.gl/jFRTXI

    Please note that you need to make sure you point your mapped domain to the same directory that your multisite primary domain is installed in.

    Let us know if you have any further questions. We'll be happy to help!

    Best regards,

    James Morris

  • Bryan

    Thank you James,

    Here is what I did,
    Went to Ipage Added new Domain Uhbseattle.com from godaddy pointed ns over to ipage.
    Then I went to A record .... Added the Ip address 66.96.147.113 to the uhbseattle.com.

    In wordpress created site.
    Went to site dashboard added domain to be mapped got the red screen.

    However when i search uhbseattle.com it goes to fullenenterprises.com.
    I wish for it to be a site within fullenenterprises.com/uhbseattle.com but only show up like http://www.uhbseattle.com in the bar. if that makes sense..

    I attached my own screen grab... let me know if this made sense if i did this right or wrong. Thank you again for the support.
    https://drive.google.com/open?id=0ByozOnf_0Gd4TV9sZDAxdnZpZ1E
    Bryan

  • James Morris

    Hello Bryan,

    Taking a look at your settings, everything looked well. However, there are some situations where you have to disable an option in Domain Mapping in order to get the mapping to work correctly. Your situation is one of those times.

    What I've done is set Verify domain's DNS settings to No. The domain will now map correctly. I've added it for you. See screenshot: https://goo.gl/fChuon

    Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

  • James Morris

    Hello Bryan,

    Hmmm.... There's definitely a configuration issue on the hosting account for you to see symptoms like this.

    In order to help you better with your issue, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Domain Registrar Login
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • James Morris

    Hello Bryan,

    OK, it took a little digging around, but I've found the problems.

    1. In iPage you had uhbseattle doing a URL redirect to your primary domain. I've corrected this and pointed to the folder where you multisite install is located (the same folder fullenenterprises is pointed to).
    2. For the hauteluxuryproperties subsite, you had changed the primary domain in the settings to use uhbseattle as the primary domain which will not work. All subsites must use fullenenterprises as the primary domain for the site to work correctly.
    3. In iPage you had hauteluxuryproperties pointed to the wrong folder on the server. I've now pointed this to the folder where your multisite is located and mapped the domain.

    I've tested everything out and it's working correctly now.

    Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

  • Bryan

    Hi James,

    Thank you for assisting me previously on this matter... I have switched up my main domain to be automatingbusinesses.com

    Im having issues again with figuring out the domain mapping feature. I looked over what you typed and did the settings like last time but it seems that i might be missing something on the cpanel side... May I have your assistance again in this matter?

    Kindly
    Bryan

  • Luís

    Hi Bryan ,

    Hope you're doing well today!

    Working here alongside with my teammate James.

    Firstly, I marked this topic as internal to remove the public visibility in order to protect the privacy of your dashboard and control panel, so I can share a video with my tests

    I gave a look on your Multisite install and in the iPage control panel and, picking "fullenenterprises.com" as an example, it is not pointing to the correct folder (where you have the Multisite installation and where the wp-config.php is located).

    So, I went to the iPage control panel and pointed it to the correct folder. Please check:

    https://www.screencast.com/t/mZHDw2P0

    I hope this information has been helpful. If I can help you in this or other questions or if I am missing something, please let me know!

    Cheers, Luís

  • Bryan

    Okay,

    So im being told that by one of Ipage tech support helper from india said their servers are not compatible... but it was all working before. im wondering if that's their way of saying we dont know....

    So they deleted all files and dropped the servers and did a fresh install for me... i went into the wp-config and added the define( 'WP_ALLOW_MULTISITE', true );
    now i get the 500 internal error right after that.. amazing.... when i chat with their tech support they cant seem to figure out what i want when i explain that information to them...
    I'm really lost now.... keeping my spirits up.

    Bryan

    • Bryan

      Hi James Thank you for following up with me on this matter,

      Yes in fact I was able to get a lot of things figured out from this whole process... lots of learning!!! I was able to get them to update php from 4x to 5.6 in which they will be upgrading to the higher versions soon, mod deflate was inactive on the server, they enabled opache for me and fixed my file directory issues... wow...

      other than that,
      Could you please point me in the right direction on how to point at folders? I think this is where i keep falling short... i dont understand what it is that im doing when it comes to directories and domain pointing and how to explain this to my clients when they want to map their domain on my site.

      Kindly
      Bryan

  • Luís

    Hi Bryan ,

    Hope you're doing well today!

    Firstly, I am glad you have solved all the issues with your Multisite installation.

    Could you please point me in the right direction on how to point at folders? I think this is where i keep falling short... i dont understand what it is that im doing when it comes to directories and domain pointing and how to explain this to my clients when they want to map their domain on my site.

    As was mentioned above, the new domains added, should always point to the folder where you have the Multisite installation (where the wp-config.php is located).

    By default, when you add a domain in your Host control panel or on cPanel (using the Addon Domains option) it will be pointed to a subfolder (with the domain name), so, you need to edit and change the "Document Root" to point it to the right folder.

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís