Domain mapping Version 4.4.3.1 broke Divi for me

I have Divi installed in a multisite network. When I installed version Version 4.4.3.1 of domain mapping, I started getting errors on frontend of site that prevented it from loading the Divi Visual Builder. The errors were related to insecure versions of JS assets being delivered to the site which is running on HTTPS.

Interestingly enough, this did not affect custom mapped domains. Only the original *.domain.com subdomains.

My config:
https://monosnap.com/file/rRCMKYt1VFQnfNMf4idrQURKtOgkY7.png
https://monosnap.com/file/LWS5HURzJRbT9Pmw1c28vAhbF7Iu2Q.png

IDK if this is a configuration error on my part or a bug in the release but wanted to point it out just in case. I downgraded to v4.4.3 and all is well, so no emergencies right now.

  • Audra @Zindo
    • Design Lord, Child of Thor

    Hi Denny,

    I'm having a similar problem. I updated the mapping plugin when it first came out and all was fine, but today Divi forced me to update my theme and now I can't get the builder to load saying 3rd party plugins are preventing it from loading.

    I've narrowed it down to the domain mapping, but support, wpengine so far haven't been able to resolve it. I've submitted a ticket to Divi so I'll let you know where we find the challenge.

    In the meantime, I'll try to downgrade my mapping plugin as well and see if that resolves it for me. BTW, where do you find the previous versions? I haven't had to do that yet and not sure where to find it.

    Thanks, glad to find out I'm not going crazy as I just couldn't figure out what could have changed.:slight_smile:

    Audra

  • Audra @Zindo
    • Design Lord, Child of Thor

    Update:

    Denny,
    I found the last versions and downgraded the mapping plugin and it works now! That was it. It's the new version that is causing the builder issues.

    Thanks so much for posting this. I've spent my whole day trying to solve this.

    Much appreciation!
    Audra

  • denny
    • Design Lord, Child of Thor

    No problem, glad it was of benefit :wink:

    To be fair I don’t know if it’s a domain mapping or Divi issue. I just noticed it after upgrading domain mapping, it only happened on certain domains, and there are notes in changelog about updates to handing of SSL stuff so I put all that together and assumed it’s a wpmudev fix. But it’s entirely possible Divi is doing something in a non-standard way that causes domain mapping to miss some of the assets.

    Let me know what you hear back.

  • Ben
    • The Reaper

    echo $test = admin_url('ajax_url');

    if your site is url is https and the test is showing a non-https (like it is for me) then i think that indicates an issue with domain-mapping

    Whats weird is some sites on my network work, some dont, and then some all the sudden do work.

    I think there is some sort of admin_url caching situation introduced

  • denny
    • Design Lord, Child of Thor

    Update: I had to downgrade to 4.4.2.5 to fully resolve this. While 4.4.3 didn't give me the broken Divi editor on normal subdomain installs, further testing revealed that admins were always being redirected to subdomain URL even if trying to login at custom domain. This created an issue where users couldn't even login (because the redirect was happening somewhere between them entering sign-in info and actually getting logged in).

    I haven't experimented further, but 4.4.2.5 seems to be working as intended.

  • James Morris
    • WordPress Enthusiast

    Hello @ all! :slight_smile:

    I hope you all are well today.

    Regarding the login issues with 4.4.3...

    We've recently discovered a little bug that is being worked on. A hotfix will be available soon to address this. A temporary workaround is to perform the following steps:

    Login to the effected subsite
    Navigate to WP Admin -> Tools -> Domain Mapping
    Toggle the Front end redirect should be: option to Disabled and entered domain should be used then back to Directed to mapped (primary) domain.

    Once you do this, the login issue should be resolved.

    The latest version of Domain Mapping was suppose to address the issues with Divi. If this is not the case in any of your situations, we would be most interested in investigating this further.

    If you are experiencing compatibility issues with Divi, please grant us access to your site and server so we can perform some advanced debugging?

    NOTE: Please make a full backup of your site before sending the following information.

    Please visit the Contact page and complete the form with the following information:

    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Option: I have a different Question

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    ~OR~

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • denny
    • Design Lord, Child of Thor

    Thanks @jrmorris77. I appreciate the instruction but I'm sticking with the working version of plugin for now.

    I was definitely experiencing a Divi-specific issue where a couple JS assets were not loading because the URL were being accessed via normal HTTP protocol and not over HTTPS. I have wildcard SSL set up for subdomains and this is where the error occurred. Custom mapped domains had no issues.

    The bug completely breaks the editor so unfortunately I can't enable it on live site for you to see, but I don't currently have a staging environment available for you to see it in either.

    Establishing a proper staging environment is one of my priorities over the next week or two so will let you know if that becomes available before the Divi issue is identified and resolved.

  • Ben
    • The Reaper

    The issue is triggered when in the domain mapping settings the setting is set to:
    Front end redirect should be: disabled and entered domain should be used

    If setting is set to: directed to mapped (primary) domain
    there is no issue

    So for the quick fix set it to: directed to mapped (primary) domain

    Good luck

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.