Domain Mapping w/ HTTPS - My Scenario 1 - Staff Check In :)

Hi WPMUDev,

I hope your day is going well :slight_smile:

I have some Qs regarding Domain Mapping and working w/ HTTPS.

Here is a beginning scenario to work from, and I am hoping to have y'all confirm that my next iteration is headed in a good direction.

Primary:
Database values:
SITEURL - https
HOME - https
Domain Mapping Network Settings:
Server IP: 185.56.85.36
Admin Mapping: Original
Login Mapping: Original
Cross-Domain: Yes
Verify: No
Force HTTPS Login/Admin: No
Force HTTPS Frontend: No

Subsites:
Database values:
SITEURL - https
HOME - http
Domain Mapping Subsite Settings:
Protocol: http

Fresh Install of WPMS

Primary site database values for SITEURL and HOME have been changed to use HTTPS via Host's WP Tool for SSL Configuration.

Subsite database value for SITEURL has been changed to use HTTPS via network > sites > edit > settings

Theme: Twenty Fourteen

Plugins: (i=installed, a=active, n=network active)
Domain Mapping - n
WPMUDev Dashboard - n
Jetpack - i
Diagnose - i

Status: Working as expected, almost!

Primary is forced to HTTPS for Frontend.
Primary is forced to HTTPS for Login/Admin.
Subsites are forced to HTTPS only for Login/Admin.
Subsites are NOT forced to HTTP for Frontend, but do default to HTTP
(I have NOT set Subsites' HOME values to use HTTPS as I know that will later cause issues with DM)

Screenshot 1: Primary Site

Screenshot 2: Subsite

Next Activated DM & WPMUDev Dashboard

Successfully applied scenario settings (see sidebar left) to DM.

Logged out, cleared browser.

Retested URLs:

Primary is forced to HTTPS for Frontend.
Primary is NOT forced to HTTPS Login/Admin.
Subsites are NOT forced to HTTPS for Login/Admin.
Subsites are NOT forced to HTTP for Frontend.

Logged in to https://tivism.com

Mapped URL http://www.tivism.org to https://tivism.com/tivismorg-secure-access

The domain validation wheel just spun, though I have 'Verify' set to 'No'

The domain mapping worked, in that http://www.tivism.org will now resolve.

However all kinds of crazy redirect loops and http/https switches ensue when trying to login and navigate to site dashboard > frontend or to/from other subsites in network.

So, in this situation, I am wondering which way y'all would go:

1) Setup without changing any database values to use HTTPS - let DM handle all of this.

Server IP: 185.56.85.36
Admin Mapping: Original
Login Mapping: Original
Cross-Domain: Yes
Verify: No
Force HTTPS Login/Admin: Yes
Force HTTPS Frontend: Yes

2) Leave database settings in place for SITEURL & HOME as discussed above - bring DM Network Settings inline with the database settings:

Force HTTPS Login/Admin: Yes
Force HTTPS Frontend: Yes

2a) Leave database settings in place for SITEURL & HOME only for Primary, Subsite SITEURL values set to HTTP default - bring DM Network Settings inline with the database settings:

Force HTTPS Login/Admin: Yes
Force HTTPS Frontend: Yes

Thanks for your insights!

Kind Regards, Max

PS. SUPPORT ACCESS is ACTIVE - Please log in and poke around if you'd like to see behaviors! Diagnose Plugin will show you further server info :slight_smile:

  • wp.network

    Again, to be clear, the Q is:
    So, in this situation, I am wondering which way y'all would go:

    1) Setup without changing any database values to use HTTPS - let DM handle all of this, using:
    Force HTTPS Login/Admin: Yes
    Force HTTPS Frontend: Yes
    2) Leave database settings in place for SITEURL & HOME as discussed above - bring DM Network Settings inline with the database settings:
    Force HTTPS Login/Admin: Yes
    Force HTTPS Frontend: Yes
    2a) Leave database settings in place for SITEURL & HOME only for Primary, Subsite SITEURL values set to HTTP default - bring DM Network Settings inline with the database settings:
    Force HTTPS Login/Admin: Yes
    Force HTTPS Frontend: Yes

    ?

    Cheers, Max

  • Tyler Postle

    Hey Max!

    Hope you're doing well today and thanks for your question.

    How do you have it mapped? I can't navigate to your mapped subsite settings, gives me a redirect error. Could be due to our support login.

    Either way, do you have the domain mapped with https or http or force none? I'll attach a screenshot of the setting I'm referring too. It looks like you have it set "http". Try changing it to https :slight_smile:

    As for your options above, I would go with #1 and just let DM handle it all.

    The options in the screenshot, http and https were added so you don't need to use any other forcing methods :slight_smile:

    Hope this helps Max! If I missed anything here just let me know.

    Have a great rest of your weekend.

    Cheers,
    Tyler

  • wp.network

    Hey @Tyler Postle thanks for your reply.

    1) How do you have it mapped? I can't navigate to your mapped subsite settings, gives me a redirect error. Could be due to our support login.

    I can't navigate to subsite setting anymore either.

    It was setup as described above:
    Protocol: http
    as in http://www.tivism.org

    2) Either way, do you have the domain mapped with https or http or force none? I'll attach a screenshot of the setting I'm referring too. It looks like you have it set "http". Try changing it to https :slight_smile:

    Again, it is set to:
    Protocol: http

    I do NOT want to map the frontend of mapped domains to use HTTPS

    I want to FORCE frontend of mapped domains to use HTTP only.
    (this is why database values for subsites were only changed for SITEURL and not for HOME)

    3) As for your options above, I would go with #1 and just let DM handle it all.

    I agree.

    However, my host recommends taking the general course I have described in the ticket, and I was simply wanting to explicitly show that it don't work too well and that #1 is the approach that WPMUDev would consider as best-practice and which should be expected to work.

    I appreciate your input. :slight_smile:

    Cheers, Max

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.