Domain Mapping- Why are there two versions of my site running; the "www.mysite.com" and &q

On my multi install, i have domain mapping on a clients subdomain site. It seems to show two versions of the site when you use and do not use the 'www'. This issue is here: http://www.GillardoFitness.com leads site when i used a 'coming soon' plugin. and GillardoFitness.com seems to lead to the correct (current) site.

I have removed the plugins completely from the main multisite and tried various other problem solving testing, however I am stuck .

This is puzzling to me for I have no issue with another clients domain mapping on another subdomain.

Before I go in greater details, just wanted to know if there was any quick fixes I might be missing? thx.

  • aaronjamesweb
    • Site Builder, Child of Zeus

    yes, entered without 'www'.

    ok so removed both 'siteoffline' plugins entirely about hr ago. Just checked both url's (www.gillardofitness.com and gillardofitness.com) still same issue.

    So I am taking a guess and thinking maybe something with my hosting? I have HostGator. Could there be need for excess time for server propagation?

    Also since the domain mapping works on another clients subdomain, I am wondering if this issue has anything to do with the SSL. I recently had HostGator get me SSL and dedicate IP. Again everything works fine with other subdomain mapping. Also everything works fine when I am logged into the site from wordpress (wp-admin).

  • Jack Kitterhing
    • Code Norris

    Hi there @aaronjamesweb

    I hope you are well today and thank your question.

    What sort of SSL do you have? Is the SSL enabled on both of these domains?

    How long ago was the domain mapped? A domain can take up to 48hrs to propgate properly even though that doesn't appear to be the issue here.

    Do you have any caching plugins installed?

    Thank you!

    Kind Regards
    Jack.

  • Jack Kitterhing
    • Code Norris

    Hi there @aaronjamesweb

    Re-active the cache plugin, clear the cache then deactivate and then see if that makes a difference?

    Entering it in your browser bar? It doesn't really matter, some sites are set up to use and show the www. in which case if you put it in without the browser will add it :slight_smile: It's not really a big thing to use these days though.

    You should be just changing the A record for that on the DNS manger :slight_smile:

    Thank you!

    Kind Regards
    Jack.

  • aaronjamesweb
    • Site Builder, Child of Zeus

    @ Jack...ok so I know I'm suppose to just change the A record, and I have done that with another clients site and its working correctly.

    So back to this issue, the problem was the WP Super Cache plugin. I disabled it, site worked fine later.

    However, I have question on an interesting configuration. I set the name servers on my clients vanity domain to my multi site name servers and the operation is working. Why is that, and why/how is this different from changing the A record?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.