Domain Mapping With Plesk

I recently installed Wordpress 3.3.1 on my Plesk server.

After struggling a bit to get the wildcard subdomains working everything is working great.

domain.com works &
subdomain1.domain.com works

Then I installed your domain mapping plugin and it seems to do what its supposed to.

newdomain.domain.com gets 301 redirected to newdomain.com

Unfortunately I'm getting the Plesk "Web Server's Default Page"

I have tried everything to get this to work. I spoke to the guys at my hosting company and they say the server is working fine and it seems the plugin is working fine they just aren't working together.

Any help would be really appreciated. I'm hoping its a small fix like the wildcard changes!

Thanks

  • Timothy Bowers

    Hey brandblasting, welcome to the WPMU Dev Community forums! :slight_smile:

    Yeah seems both are working fine there. I think the issue is the IP for your site.

    You see when a domain gets mapped in through its A record you point it to your sites IP. I suspect if you type your IP address into the browser then you will see that same Plesk page?

    Thats the problem.

    The domain need to fall upon your WordPress install so that it gets mapped correctly. Is this a dedicated IP?

    If it is then ask your host to configure it so that when you enter the IP in your browser, you are taken to your WordPress multisite installation.

    Everything should then work. (once the DNS is resolved)

    If you don't a dedicated IP then you would either need to buy one (their cheapish), many companies will force you to buy an SSL cert which comes with an IP or you can add those domains to your virtual host file.

    Its been a while since I used Plesk, but I think they called Addon domains or Parked domains, those are the terms for cPanel so if they not for Plesk, then its their equivalents.

    If you are hosting peoples websites then they will most likely want to maintain their DNS control, so addon and parking isn't an option.

    I hope this helps, if you need any more help then please just let us know.

    Take care.