Domain mapping with SSL present

We have multisite set up to use subdomains. Dangeroustactics.com is primary domain. newthoughtforum.dangeroustactics.com is a subsite. We've successfully mapped newthoughtforum.com as the domain for this site. Everything was working great until I installed SSL. There is a shopping cart, so the site requires it.

Some browsers are not displaying some of the page elements, while others are still saying the site is not secure, even though I've confirmed that certificate is installed properly.

After looking into it further, I've verified that all queries involving the mapped domain (newthoughtforum.com) are rendering properly via https. However, there are still page elements being called through the subdomain (newthoughtforum.dangeroustactics.com). The fact that every page of the site is delivering mixed content (both secure and not secure) is causing issues with how the site works.

Does the domain mapping plugin not work on all page elements? Is domain mapping plugin installed or configured incorrectly? How are people running SSL in this type of setup? Am I required to have two certificates, one for the subsite's domain and another wildcard for the entire primary domain and all subdomains? In other words, do I need to have a separate certificate for the subdomain in order to have a secure subsite on this multisite?

Support access is enabled. I'm happy to provide any details necessary. Any insight is much appreciated.

  • Vaughan
    • Support/SLS MockingJay

    Hi christian,

    Hope you're well?

    It should work ok with the way you have set it up,but I do see some issues with insecure content.

    For some reason though, I can't use the admin with the mapped domain in ssl mode,it always has to be used with the original domain. When i try newthoughtforum.com/wp-admin

    It just returns me to the homepage.

    I'm going to ask a colleague for some assistance with this, hopefully, he might be able to spot something i'm missing.

    Thanks

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    I sorted the homepage which is now showing as secure with no insecure content.

    I changed the mode back to http in the Tools menu for that Domain Mapping on that subsite.

    Then I re-uploaded the images again to the page in the theme customizer

    As the site was using newthoughtforum.com/wp-admin the images were then uploaded using that domain and not the original domain.

    Hope this helps

  • Christian
    • The Incredible Code Injector

    It indeed seems to have addressed the issue. The site is now rendering as expected. I really appreciate the assist! The login page is /signin, not /wp-admin. this is a security setting we have. I did not realize that would be an issue for you after having enabled support access, my apologies.

    I have to admit, I'm not sure I follow how you fixed it though. I have two more domains to secure with ssl and would love to not have to bother you with this again. Am I understanding that the issue was simply related to the fact that the images had been uploaded prior to the site being migrated to it's proper domain? I had used Velvet Blues to redirect URL's after moving the site, but perhaps the background images were missed, and that's what was causing the hiccup. Does that sound accurate?

  • Vaughan
    • Support/SLS MockingJay

    Hi christian,

    Am I understanding that the issue was simply related to the fact that the images had been uploaded prior to the site being migrated to it's proper domain? I had used Velvet Blues to redirect URL's after moving the site, but perhaps the background images were missed, and that's what was causing the hiccup. Does that sound accurate?

    Yes, that sounds accurate.

    All I did was simply edit the front-page you had making sure I was in the admin using the new mapped domain, not the original sub-domain in the URL, then re-added the images again to the page, this then changed the URLs to the mapped domain for those images.

    The insecure SSL plugin tends to take care of most of those, but it's not perfect and sometimes URL's can get missed.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.