Domain set up in multisite

I’ve not gone completely live with the network yet. I want to point a domain name that is currently pointed at another server to its position in the new network, not the main site. I set the @ to the new IP address and added an “a” record pointing to the subdomain. After waiting on propagation I got nothing. support is accessible.

  • Vaughan
    • Support/SLS MockingJay

    Hi Scott,

    Hope you’re well?

    Domain-mapping requires a unique static IP address to work with A records & the IP address must resolve to your multisite documentRoot.

    To test this, enter your IP address into a browser, if you see your multisite, it should work, if you see a default server page,or anything else other than your multisite signup page, then it will not work. You would need to speak to your webhost about that, but it might not be possible with your multisite being in a subdomain itself rather than the TLD domain.com

    You maybe able to try parking the domain on your server instead and thenpoint it at your multisite root folder (where wp-config.php resides)

    Hope this helps

  • Scott
    • Design Lord, Child of Thor

    So…I originally did NOT put the network on the TLD, JGS. There’s about 10 sites to end up there. I thought it best to start with the smaller sites as some needed conversion to WP. I started them and recently imported JGS and am putting on final touches. My next step? Change the server to the JGS. which if I read correctly above would fix the issue since it is currently a subdomain?

  • Vaughan
    • Support/SLS MockingJay

    Hi Scott,

    Yes, pretty much, though there are other conditions for domain mapping to work.

    The main point being that the multisite must have it’s own unique static IP (dedicated IP)

    & when entering the ip into a browser, it must display your multisite, not a default server page.

    I think on many hosts, you can only assign a dedicated IP to the primary domain on a webhost account (shared hosting), so if you have shared hosting, you will need to make sure your multisite is on the primary domain of your CPanel account, add-on domains can’t be assigned a static IP address on shared hosts.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.