Domains can't be selected by users in Internet Explorer

Hi,

I'm using the Multi Domain plugin together with the Domain Mapping plugin.
So I copied dm_sunrise.php to wp-content and renamed it into sunrise.php
Also adjusted wp-config.php so sunrise is on.

Created the domains in the dashboard. All below domains now point to the wordpress install from gemeentehollandskroon.net:
dghk.nl
annapaulowna.net
hollands-kroon.nl

they all have the status Public.

For all domains is a wildcard (*) available in the dns entries.

Okay, now the problem I have:
When I want to register a site in Firefox I can see only 1 domain name and I'm not able to use the dropdown.
In Internet Explorer I can't see any domain name at all, but I can use the drop down.
You can use this link in your browser or please see the image.

When I want to create a new site within the dashboard, all domains are available as you can see below.

Is this plugin related or has it to do with some (mis)configuration?

Greetings,
Age

  • Patrick
    • Support Monkey

    Hi @jongag1

    If things are working correctly within the dashboard, but display differently depending on which browser is being used, then I doubt it has to do with configuration.

    This could be related to some problems members have been having with the Domain Mapping plugin interfering with certain displays (mostly the TinyMCE editor in the post editor). There's a new update coming very soon for that.

    Also, could you post the link to your test page again please? The one you posted above can't be clicked.

  • jongag1
    • The Crimson Coder

    Hi!

    @Timothy, I noticed the created site, so that's working okay!
    On a different computer it was looking just fine so perhaps cashing was the problem...

    When opening in Firefox the dropdown is working.
    Opening in IE (windows8, desktop) is not working, empty dropdown.
    Opening in IE (windwos8) is working okay.

    @Patrick, after installing the latest update the TinyMCE editor is just right again.
    http://gemeentehollandskroon.net/wp-signup.php?new=test.dghk.nl

    When opening this link it takes you to the regisdtration page (if you're logged in),
    testdghknl is entered in the website domain field. It's better to just show test in that field and that the domain is selected automaticly.

    @both, what bothers me most is that when I want to visit the main site (gemeentehollandskroon.net) it redirects to annapaulowna.net.... Also logging in is a problem now. When I click login on the redirected site the login page from gemeentehollandskroon.net get's opened. And after logging in it takes me back to annapaulowna.net again, and says I'm not logged in.

    Are you getting confused? I am! Hope I made myself a bit clear to you guys!

    Greetings,
    Age

  • Timothy Bowers
    • Chief Pigeon

    Hey again.

    Can you check your htaccess for any redirects?

    Any plugins doing redirects?

    Anything on the front page of the main domain doing a redirect?

    Have you mapped a domain to the main site? If so you would need to remove that.

    @patrick will need to test IE issues as I don't currently have access to that, sorry.

    Take care.

  • jongag1
    • The Crimson Coder

    Hi Timothy,

    The Domain Mapping plugin was 'causing' the redirect... After deleting the other domains it's working normaly. Ain't it possible to forward dghk.nl to the original blog (gemeentehollandskroon.net)? I thought that could work...

    Will wait for Patrick's feedback as well.

    Thanks,
    Age

  • Timothy Bowers
    • Chief Pigeon

    No it doesn't forward it in.

    It maps one over the other. To be honest this causes issues like you witnessed so I'm going to change the forum here and then mark this as a bug report. I think it would be better if the domain mapping option simply didn't appear on the main site.

    To forward a domain in you can do that in cPanel or wherever you manage your DNS.

    Or you could just map it to another site and use it like a portal or gateway, i.e. some unique information about your network/sites so that google get something extra to index and send you traffic with.

    Take care.

  • Barry
    • DEV MAN’s Mascot

    Ain't it possible to forward dghk.nl to the original blog (gemeentehollandskroon.net)? I thought that could work...

    Are you trying to map a domain in the main blog? There are restrictions in the domain mapping plugin to explicitly prevent this as it causes a *lot* of problems - if you are managing to do this, then that may be the reason you are having issues.

  • jongag1
    • The Crimson Coder

    Hi,

    @Patrick, yes please, in IE the dropdown is empty. Registration is possible again. The title of this topic should be changed into: Domains can't be selected by users in Internet Explorer :slight_smile:

    @The others, what I tried to achieve is that when dghk.nl is entered in the address field it shows up as dghk.nl but showing the gemeentehollandskroon.net content.
    So if someone would click on Listings (Info Gids in Dutch) it would show the content and in the address field would show http://dghk.nl/info_gids/ instead off http://gemeentehollandskroon.net/info_gids/

    Greetings,
    Age

  • jongag1
    • The Crimson Coder

    Guys,

    I'm getting lost here.... Saw your message and logged in to test.
    Noticed the dropdown suddenly is working in IE (but it's at the bottom)... Thought I was getting crazy.

    Only thing I did was activating Buddypress, so I deactivated it again and yes there was the empty dropdown again!

    So without Buddypress being activated the dropdown in IE is empty, when it's activated it's okay.

    Putting in the above code is working the same as activating Buddypress. The domainnames do! get vissible in the dropdown, thought the dropdown itsself goes to the bottom of the page.

    Gr,
    Age

  • jongag1
    • The Crimson Coder

    @Patrick, could you please test it again in IE? The problem in the thread above this post was caused by the JS Minify Option within W3 Total Cache.
    I just upgraded to Windows 8 and now the dropdown is working in Internet Explorer. Just curious if it's working for you also.
    If so, the topic can be marked as resolved.

    Gr,
    Age

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.