don't allow comments on repeating Events

When I create a repeating event, I cannot disable comments. I deselect the "allow comments" checkbox, and although it previews without comments, all the repeating events show an option to comment.