Don't need to send out the email to members after we accept as our member

Hello,
I am using Membership2 plugin, which is such a nice plugin, so easy and flexible. But my business is small so at this stage we only have one level, agent - free. Since we implement user approval registration process, we already sent out the user approval email, and one accepted as our user, becomes agent automatically. Therefore, we do need to send out membership approval email. It is redundant. Please help me not sending out this auto emails after I change their membership level to "Agent".

Thanks,
Austin

  • Adam Czajczyk
    • Support Gorilla

    Hello Austin,

    I hope you're having a nice day!

    Please follow these steps in your site's dashboard:

    1. Go to "Membership 2 -> Add-ons" page and make sure that the "Additional Automated Messages" add-on is disabled

    2. Go to "Membership 2 -> Settings -> Automated Email Response" page and then:
    a. select e-mail response from the drop-down list
    b. click on "Load Template" button next to drop-down list
    c. make sure that the toggle switch next (on the right of) to the message name is switched off (grayed)
    d. scroll down the page and click "Save Changes"
    e. repeat steps "a" - "d" for each template from the drop-down list.

    This way you would disable all automated e-mail messages.

    I hope that helps!
    Best regards,
    Adam

  • austin
    • Site Builder, Child of Zeus

    Hello Adam
    I couldn't say thank you more for this great help.
    Even though I turned off all the auto email responses, but I have one other question.
    When these emails are sent to the subscribers or members, email address sent looks like this. (gooddaz4@box885.bluehost.com) This email, I asked to the bluehost, is generated automatically by the server depending on our username, but I want to know whether I can change this email address to more common ones that we use daily or admin email address. Please do not burden on this question. I am just asking to you since you are very much knowledgeable guy.
    Best,
    Austin

  • Adam Czajczyk
    • Support Gorilla

    Hey Austin!

    This is unfortunately caused by server configuration. Some hosting providers implement their own strict policies on e-mails that are sent automatically by scripts running on the server (such as WordPress) via PHP "mail()" function.

    Since you already asked them about it and they weren't able to help you more than just by explaining situation, I think the solution here would be to switch your entire WordPress to use SMTP to send e-mails instead. This can be achieved with one of these plugins:

    https://pl.wordpress.org/plugins/wp-smtp/

    https://wordpress.org/plugins/wp-mail-smtp/

    https://pl.wordpress.org/plugins/easy-wp-smtp/

    I hope that helps :slight_smile:

    Have a nice day,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.