Don't show user roles after migration

Hi Team,

It’s a little bit out of your scope, but maybe you can help me.

That would be great.

We migrate the WordPress MU website to another server and everything is working fine except 1 thing:

– The user roles doesn’t show up anymore

See this image:

=> http://screencast.com/t/FAC1dpVp

Do you know why?

Thank you in advance for your help!

Stijn

  • DavidM
    • DEV MAN’s Mascot

    Hi Stijn,

    No worries about posting general WordPress questions to the forum. While our primary focus is on supporting the plugins and themes here, the forum is totally open to discussions surrounding WordPress and other members may have some insight on issues like this so it’s generally helpful to post these issues here.

    That said, I see you’re using BackupBuddy, did you use that for the migration? They have a beta version that’s apparently Multisite compatible, did you use that version?

    It seems likely to be an issue in the user database, have you checked your wp_options table in the database for wp_user_roles?

    There should be some mention of other roles in there.

    On the off chance it might help, perhaps you could try installing the User Role Editor plugin to see if the roles are available there?

    http://wordpress.org/extend/plugins/user-role-editor/

    -David

  • Rogier & Stijn
    • The Incredible Code Injector

    Yes thank you David.

    I used the BackupBuddy.

    And I think it’s in the wp_user_roles.

    This is what someone told me:

    “One way to fix this (a bit complicated) could be to try and copy the appropriate wp_## (where the ## is the number of your site) into the new site’s wp_sitemeta data. Basically you’ll be copying the user roles info and users into the new site manually via mysql.”

    But I don’t understand what to do.

    Site ID 1 is the Main website, but in the database there isn’t ‘wp_1’. Is that correct?

    Which specific data should I copy? Should I copy the complete table?

    Thank you in advance for your great help!

    Stijn

  • Rogier & Stijn
    • The Incredible Code Injector

    Hi David,

    I finally found the problem. It was in the database prefix.

    By the migration I changed it form ‘tnxtbasis_’ to ‘wp_’.

    And the prefix will be used in the option table.

    In the new migration I didn’t change the prefix and it works fine! :slight_smile:

    Thank you for your support!

    Stijn

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.