Double Pictures

When I set a featured image for a new product, I get two photos displaying. One is the dominant and one is a thumbnail directly below it. I tried searching through my theme's function.php and commenting out it's function to display post's thumbnails but had no success. When I ventured to the marketpress/marketpress-includes/template-functions.php and commented out

$image = get_the_post_thumbnail($post_id, $size, array ('class' => 'alignleft mp_product_image_'.$context, 'title' => $title));

.. part of my problem was solved. The thumbnail was removed from the products page, however I also lost the thumbnail on the product list. Is there anyway of fixing the double image problem without losing my product list thumbnail?

Many thanks in advanced.

  • Timothy
    • Chief Pigeon

    Hey realsparks, welcome to the WPMU Dev Community forums! :slight_smile:

    Can you provide screenshots showing what the issue is here, perhaps draw on them and mark what is happening in case it is not entirely obvious at first.

    You could also provide a link if you wish.

    Take care.

  • Timothy
    • Chief Pigeon

    I really like that design, nice a simples! :slight_smile:

    I think this might be something theme related I'm afraid and would know without seeing the theme properly and how it functions.

    I'm guessing you hadn't just posted that image on the page also? Perhaps a screenshot of the editor for that page?

    Take care.

  • Timothy
    • Chief Pigeon

    By the looks of the other thread, the first user had inserted both images into the editor when creating a product. The theme then displayed both the featured image and the image they inserted in the page.

    The second person on there was looking for the following function in his/her theme:

    the_post_thumbnail();

    This grabs the posts thumbnail and echos aka prints it onto the page as well has having a featured image spot.

    It would be hard to know for sure without spending a little time looking at the theme you are using, looking at the code of the theme and how its rendering it on the page.

    But if you look in your theme files for the_post_thumbnail(); then you might find where it is being pulled providing it uses standard WP methods.

    Is removing the featured image not an option for you?

    Let me know how you get on. :slight_smile:

    Take care.

  • realsparks
    • WPMU DEV Initiate

    Unfortunately, removing the feature image would both remove the main image on the product page and the thumbnail on the pervious page. Is there anyway that you can help me get around my problem I stated in my initial question?

    **When I ventured to the
    marketpress/marketpress-includes/template-functions.php

    & commented out

    $image = get_the_post_thumbnail($post_id, $size, array ('class' => 'alignleft mp_product_image_'.$context, 'title' => $title));

    .. part of my problem was solved. The thumbnail was removed from the products page, however I also lost the thumbnail on the product list. Is there anyway of fixing the double image problem without losing my product list thumbnail?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.