download failed, bad request

when I tried to install new plugins in the WPMU DEV, it showed me this message. It occurs without any reason. I did not install any plugins recently.

I disabled/reinstalled the WPMU DEV, but still did work.

BTW, I could not update plugins either.

  • Adam Czajczyk
    • Support Gorilla

    Hello mazin,

    I hope you’re well today and thank you for your question!

    This might be caused by some issues with connection which in turn might be a result of either some security plugin interference, some kind of firewall on a server or some blacklists set for certain networks/IP numbers or malfunctioning/misconfigured cURL library… There’s some more possible reasons for this :slight_smile:

    That being said, I would like to take a closer look at this so would you mind enabling support access to your site for me, please? You can do this on “WPMU DEV -> Support” page in your site’s back-end.

    Please also follow these steps:

    1) Enable WordPress debugging by adding following lines to the “wp-config.php” file of your site

    define(‘WP_DEBUG’, true);

    define(‘WP_DEBUG_DISPLAY’, false);

    define(‘WP_DEBUG_LOG’, true);

    Make sure that these lines are above the “/* That’s all, stop editing… */” line.

    2) Once they are there, try to install some plugin to replicate the issue

    3) After you get an error message again, please

    – download the “debug.log” file from /wp-content/ folder of your WordPress

    – rename it to “debug.txt”

    – attach to your response post here.

    Best regards,


  • Adam Czajczyk
    • Support Gorilla

    Hello mazin

    Thank you for enabling support access and providing the debugging log.

    I have checked the site and consulted it with our admins and the problem here is that “something” on your side is “force overriding” a user-agent string for outgoing connections. When you trigger install/update of our plugins the site connects to our servers. There are some checks performed to make sure that you’re eligible for installs/updates and to prevent abuse. Therefore, we do check if a proper API key was sent, if you got an active Membership and, among other security precautions, there’s also a check for a user-agent string to make sure that the call was actually made by WordPress powered site.

    While the default – and expected – user-agent string here should be just “WordPress”, in case of your site it’s “d10fa6efd5566ca739b107b2f18c05a8”

    Most likely this is caused by a theme or by some plugin that’s hooking to “http_headers_useragent” WP filter. Please conduct a full conflict test as described on this flowchart here:

    This should let you identify the source of the problem and we could then decide on further steps to take.

    You might also try a workaround (though I didn’t have a way to test it, so I can’t guarantee it would work fine) as follows:

    – create an empty file with a .php extension (e.g. “fix-wpmu-user-agent.php”:wink:

    – put following code inside using a “clean text” editor (such as e.g. Notepad++, Sublime or similar):


    function fix_wpmu_user_agent() {
    return 'WordPress';
    add_filter( 'http_headers_useragent' , 'fix_wpmu_user_agent', 100);

    – upload the file to the “/wp-content/mu-plugins” folder on your server; if there’s no “mu-plugins” folder inside “wp-content” folder, create it

    This might help, but please note that it’s not tested (I didn’t have any way to test it). In case it didn’t help or it did break your site, just remove the file from /wp-content/mu-plugins.

    Let us know how it worked for you.

    Best regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.