Download / Media Protection Not Working

Hi guys, I've followed the video and manual for setting up media protection, but alas, my URLS are still showing the wp-content/uploads URL.

I need to be able to mask URL's so the user can't copy/paste and email to another person. I want the user to SEE the Media, but not the correct URL.

I have a group set up called "Protected Media" and have assigned two images to that group. The images are shown on a protected member page, but when a member of that subscription visits the page, the unmasked URL is shown. I tried changing the rule to negative as well, but that didn't help.

Can someone please help?

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, it's my old friend Running Alpha Admin!

    There could be a couple of things causing this; a settings error or a lack of sufficient memory. To rule out the first one, make sure you have the group itself set to strip out query strings (the first setting under the add URLs box when adding or editing a URL group). If you've got a caching program running, it's likely adding strings to the end of all your image/media URLs, we want to skip over those.

    The memory issue is a little less likely and a little less obvious. Rendering an image or media file in a protected URL takes more memory than just displaying it, and instead of throwing an error, your site just won't mask the URL. Clever, huh? (not really.)

    Let's rule out the first issue first, then dig into a possible memory issue if that doesn't fix it up.

    Happy Friday!

  • Running Alpha Admin
    • Design Lord, Child of Thor

    Hey!!! It's Michelle! :slight_smile:

    Okay, Maybe we should back up a sec. Are you saying I also need to create a URL Groups via Membership > URL Group to mask links? That may be the problem there. I didn't see anything about that in the instructions I read/saw. Can you explain further?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.