Downloading of Images

Hi,
I am having trouble uploading images to my site. The site is hosted by Godaddy. I have tried to get help from them with no success.
They have changed the Php.ini file, now set as ; File upload = on, Post Max=128m, upload max file size=128m , Max execution= 180, Memory limit= 128m.
I am not getting any error messages but the image turns into a thumbnail, which, when I edit does come out but once I place on a post goes back to a thumbnail. There are other images that were uploaded and they are visible on the media library and prior posts.
The site is still new with under 10 posts.
I am not tech savvy and would appreciate any help.

Morgan

  • Predrag Dubajic

    Hey Morgan,

    Hope you're doing well today :slight_smile:

    I'm not sure that I completely understand what's going on here, would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here: http://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Best regards,
    Predrag

  • Morgen

    Hi Predrag,

    I opened a ticket requesting assistance with the uploading of images. I am not getting any error messages but getting 'thumbnails' both on the media file and when I upload to a post.
    You may try to upload the top image to the post "How to make the most of your emailing campaign" and you will notice that it will upload as a thumbnail. But if you edit the image, it will show as a full image.
    I am pretty new in this and I have been to Godaddy, tutorials, posts and for a month now am still where I started.
    I really would appreciate your assistance.

  • Predrag Dubajic

    Hi Morgan,

    Thanks for granting access, I had a look at your site and tried uploading two images but both failed even though no error is shown in WP or browser console.

    Could you try disabling your plugins and switching to default WP theme to see if anything there is causing this strange behaviour?

    Can you also enable debug log in your wp-config.php by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'display_errors', 0 );

    Upload new image and if there are any errors this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Morgen!

    I have removed your Godaddy logins from your post. Please do never post any access credentials here. This is a publicly visible forum and its fairly well indexed by search engines. Making any data like login and password available here creates a serious security threat! I strongly suggest that you change your GoDaddy password immediately!

    In case we needed access other than via WPMU DEV Dashboard support access feature, we would ask you for it and provided with a safe way to send it to us.

    As for the issue.

    I accessed your site through the support access that's granted. First I noticed that on blog posts there's an error shown that the "get_field()" function is not defined. This function comes from "Advanced Custom Fields" plugin that was inactive on your site. I activated it to get rid of that error and make your blog posts work again.

    I have then tested image upload and I can see that the thumbnail is not created and the image is not available, except from its "Edit" screen ("Edit" image in media library). Browser console returns a lit of "404 not available" errors so this suggests that WordPress is not able to process the image and save all of its automatically created versions in a proper location.

    That being said, I noticed that you got an unusual path set on "Settings -> Media" page. It seems like a full path is given there instead of just "wp-content/uploads". It that on purpose or had it been set this way automatically? Did you change this recently?

    Also, did it start to happen after some changes made to the site or server or it just came "out of the blue"? Let me know please.

    Best regards,
    Adam

  • Morgen

    Hi,
    My sincere apologies, I did not realize that it was a public space ref passwords. I have changed the password with Godaddy, thank you.

    I had commissioned a developer to build the site and, unfortunately at the time of handing over the site he was taken ill and has not been in a position to be any assistance. As I took over the site I noted the problem and he indicated that it was a permission issue and thus all the attention moved to Godaddy.
    So, based on your findings, I would like to think that it was an oversight on the developers' end.
    If possible, may I request that you change the path so that we know that the issue has been put to rest.

    Once again thank you for your assistance.

  • Adam Czajczyk

    Hello Morgen,

    Thank you for your replay!

    This may be the path issue but permissions issue as well. Actually, I would prefer not to change that path while accessing the site via the support access because it's too risky. I mean: the support access feature is secure but doesn't let me any other access than "admin access" to the dashboard so in case anything went wrong and I'd need to access database and/or WordPress files, I wouldn't be able to.

    I understand that the developer you mentioned is nowhere "nearby" at the moment so you need assistance with it. I'll be glad to help you, however in order to be able to do this in a safe way (not to break the site and/or be able to bring it back in case anything went wrong) I would need to access your site directly. That said, please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here http://premium.wpmudev.org/contact/

    Select "I have a different question" from the drop-down list. 

    Please be sure to make a full backup of your entire site first!

    I'll then use this information to access your site and investigate the issue in-depth. Hopefully I'll be able to make changes that would solve that.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.