Drop-down Menu Not Working (Spirit)

Hi, WPMU DEV!
First of all thanks for all your cool features - really appreciate and renewed subscription yesterday.
That said I'm facing some problems:
- The drop-down menu stopped working and now show all items (and items are in the middle instead of to the left) Firefox, Safari - same problem. Clearing cache history didn't do the job either.
Yesterday I installed and and tried out Hummingbird and the Branding plugin. Any connection?
- Any tips to score higher in server respond time in Hummingbird? Can't get higher than 45.

I read about a next generation version of UpFront. Did you manage to fix the issues with virtual pages (Q&A) and the Forum posts bugs? (Discussed in other support tickets)

Have a nice day!

  • Predrag Dubajic

    Hey Oscar,

    Hope you're doing well today :slight_smile:

    - The drop-down menu stopped working and now show all items (and items are in the middle instead of to the left) Firefox, Safari - same problem. Clearing cache history didn't do the job either.

    I see some console errors when opening your site so could you try adding below code to your wp-config.php above /*That's all, stop editing.. */ line and see if it works after that:
    define('UPFRONT_DEBUG_LEVELS', 'dependencies');

    I read about a next generation version of UpFront. Did you manage to fix the issues with virtual pages (Q&A) and the Forum posts bugs? (Discussed in other support tickets)

    We did release a major update for Upfront and changed a bit how it works amongst other fixes and improvements, but unfortunately virtual page support didn't made in the release yet, we are still working on sorting this out.

    Yesterday I installed and and tried out Hummingbird and the Branding plugin. Any connection?

    Hummingbird and Ultimate Branding shouldn't cause such issues, you can try disabling minification in hummingbird just to check if perhaps that could be causing it.

    - Any tips to score higher in server respond time in Hummingbird? Can't get higher than 45.

    Since this is not related to Upfront could you start separate thread for it and grant support access to your site.
    We can then check out Hummingbird results and it will keeps things more organized.
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    You can start a new thread here:
    https://premium.wpmudev.org/forums/#question

    Best regards,
    Predrag

  • Milan

    Hello @oscar_ramsing,

    Hope you are doing well.

    Have you conducted plugin conflict test on your end ? If you are not sure about plugin conflict test please go through this manual and conduct it.
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    And it also seems to me that support access to your site has been ended, so would you please re-grant us one more time ?

    Looking forward to hearing back from you. :slight_smile:

    Cheers,
    Milan

  • Adam Czajczyk

    Hello Oscar,

    I hope you're well and thank you for granting access!

    Disabled all plugins and activated them one by one. The dropdown-menu is now working, though I don't know why - the exact same plugins are activated..

    I suppose that deactivating and activating plugin's back may have "fixed" some internal caches and/or settings used by some of the plugins and/or clear up a bit an order in which JS and CSS files are loaded, therefore it started working again. I think that it actually started working at some particular point during plugin's re-activation but I guess you're not sure when. Is that right?

    Yet, since it's working, I think let's leave it that way and observe what's going on. Let me know please in case the issue happened again and we'll continue troubleshooting this.

    Still no settings button in elements like widgets when using UpFront editor.

    I've visited your site and tried to edit it. For each and every element on a front-page that I clicked on (in Upfront editor) the settings icon (a little gray "gear" icon over the top edge of an element) was showing up. I was checking this with Chrome browser on Windows.

    This doesn't of course mean that there's nothing wrong with it but we'll need to narrow this down a bit. First, I'd like you to add following line to your "wp-config.php" file, preferably right below or above the one you added recently for Upfront:

    define('WP_MEMORY_LIMIT', '256M');

    Then please clear your browser's cache and give it another try. If this doesn't help still, please:
    - point me to the page and/or elements that do not show settings button for you
    - let me know with what browsers under what operating systems have you tested this (including version numbers).

    Looking forward for your replay,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.