Duplicate Canonical Link and Index,Follow

Hi,

When using Infinite SEO, pn any page that I have set to NOINDEX,NOFOLLOW I get duplicate entries in the page head as follows:

<meta name="robots" content="index,follow" /> (SET TO INDEX)
<link rel="canonical" target="_blank" href="http://www.xxxxx.com" />

Then further down I get:

<meta name="robots" content="noindex,nofollow" /> (SET TO NOINDEX)
<link rel="canonical" target="_blank" href="http://www.xxxxx.com" />

As I said, this only happens (a) on pages I set to NoIndex, and (b) When I use this plugin.

Please help!
Thanks

  • Vladislav
    • Dead Eye Dev

    Hi,

    Thanks to David's help and patience, we discovered that there was an issue with the plugin that conflicted with the WordPress privacy settings. If you set your site to be private WordPress will add noidex,nofollow robots META near the top of the page (among other things) - and the plugin then added its' own robots header after that. Although making your site private effectively negates any use of a SEO plugin, this obviously isn't the proper behavior and it's fixed in the latest plugin release (v1.3.5).

    Now, this doesn't exactly accounts for what you're seeing - or at least, not entirely. Here's what's the most confusing part - if your robots settings for your page are index,follow the plugin doesn't add a meta robots header at all, as that is the default crawler behavior. In fact, if the plugin dynamically determines that your settings are index,follow, it just clears that part out of the generated robots header and proceeds with other possible robots settings you may have set up. Therefore, the "index,follow" meta you're seeing in your page head shouldn't be coming from Infinite SEO.

    Could you please double-check if you're using another SEO plugin on your site? Also, could you please check your theme files to see if perhaps the theme tries to do some SEO optimization as well?

  • fortyfivecreative
    • Flash Drive

    Hi,

    I am 100% certain that no other SEO plugins are in use and the theme (Child of Thematic) does not have any SEO input either.

    If you need to log into the site I can provide access privately, however this is a client's site so would need to be done without posting any details on this post.

    Thanks
    David

  • Timothy Bowers
    • Chief Pigeon

    Hey there! :slight_smile:

    Just checking in to see how things are going and I see you are sorted now, excellent! :slight_smile:

    We haven't heard form you on this in a while. So I'm going to presume your all fixed up now and don't need any further assistance.

    However if you have more questions or need some more help then please feel free to respond in this thread or create a new one and we will be more than happy to offer assistance. :slight_smile:

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.