Duplicate Emails from Weekly Post Update

I have the latest version of the plugin (3.5.4). I have settings to send a weekly update and every subscriber is receiving 2 emails. The log shows that the update is being sent twice with exactly the same time stamps on both send actions. I only have 12 subscribers, but this is annoying and actually caused one subscriber to cancel in an attempt to eliminate the duplicates. I've read through the other threads and it appears that this problem was addressed and fixed back in 2014. It is still there for me. Let me know if there is any additional information you require. I manually triggered an email through setting and it only sent a single email.

  • Katya Tsihotska
    • Support & QA

    Hi Shirley

    Hope you had a great day!

    I'm sorry to hear about those issues that plugin is causing on your site.

    Did it works correctly before? If so, do you remember what did you recently change on your site? Did you install any new plugins?

    We need to enable debug log to see if there are any errors when emails are sending. In order to enable WP_DEBUG, change the following line in your wp-config.php file:

    define('WP_DEBUG', false);

    To this:

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );

    If there are any errors that are causing Subscribe by email to send duplicated emails it will show in the debug. So, when emails will be sent again and if the issue will occur again, then go via FTP to the /wp-content folder and find there debug.log, save it as .txt file and attach here with the next reply.

    I've also subscribed to your site to be able to confirm the issue.

    We appreciate your patience.

    Kind regards,

  • Katya Tsihotska
    • Support & QA

    Hi Shirley

    Hope you are doing fine today!

    You are right, there are no relevant errors in debug log. As the issue wasn't replucated we can't diagnose it at the moment. But I would recommend you to leave wp debug enabled for one more week, in case if issue will occur again.

    However I found some memory overflow errors in your debub log. In order to fix this I would recommend to increase memory limit to 256M. More about how to do it you can find here:


    If you have any additional questions please let me know and I’ll be happy to help.

    Warm regards,

  • Shirley
    • Site Builder, Child of Zeus

    Thank you Katya. I have created a php.ini file and will see if that resolves the errors that are showing up in the log file. In the meantime, going through this process seems to have eliminated the duplicate emails. Thank you for all your help.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.