Duplicated Site Description in Titles?

I didn't notice this issue in the past until now... not sure if it's a recent update that is causing it but I get duplicated site titles on my sites.

In Infinite SEO, my home title setting is "%%sitename%% | %%sitedesc%%"

What gets displayed is:

"%%sitename%% | %%sitedesc%%" | %%sitedesc%%"

I also notice that the Facebook Open Graph meta "title" tag description part is also duplicated...

For instance this is shown:

<meta property="og:title" content="Site Title | Site Description Goes Here | Site Description Goes Here" />

Nothing is wrong with the og:site_name though.

Please advise!

  • Alexander
    • DEV MAN’s Mascot

    Hi @Denis Lam,

    I've looked into this, and I'm really not sure what would cause the tags to double like that.

    Can you first confirm you're using the latest version? (1.6.4) Also, would you mind providing screenshots of your "Title & Meta" settings?

    Then I can try to reproduce this using your settings and see if anything comes up.

    Thanks for being a WPMU DEV member. Let us know if we can be of any further assistance.
    Best regards,

  • Alexander
    • DEV MAN’s Mascot

    @Denis Lam,

    I've done some testing, and this shouldn't be the case at all based on those settings. The title should really only be: title | description

    Can you try deactivating any other plugins you're using? It's possible that another plugin is doing some SEO modifications and appending the description a second time.

    Best regards

  • Alexander
    • DEV MAN’s Mascot

    @Denis Lam,

    I've done some testing, and this shouldn't be the case at all based on those settings. The title should really only be: title | description

    Can you try deactivating any other plugins you're using? It's possible that another plugin is doing some SEO modifications and appending the description a second time.

    Best regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.