Duplicating A Course is not working

I have been experiencing an issue with CoursePress Pro for weeks, and felt that I should bring it to your attention: Duplicating a course does not work. And, sometimes, creating a new page does not work. I get a server 500 error message page instead. When it does work it does not duplicate the course to the full extent. Only like 25% of the course is actually duplicated. With the page issue, a new page is not created. Instead, a new section is created within the same page.

  • Vaughan
    • Support/SLS MockingJay

    Hi @F. Zaria,

    Hope you're well?

    Do you have anything in your server error logs that might tell us why you received the 500 error? You should be able to find your error logs in your servers CPanel

    Also, i'm not sure setting max_execution_time is a good idea. 60 should be ok.

    Could you try increasing;

    post_max_size to 32M in your php.ini if possible?

    Hopefully that might fix this.

    Thanks

    • FZCU
      • The Incredible Code Injector

      Vaughan,

      Hi! I can't set max execution time, as I am not an avid SSH user. But, I did check the logs and found what may be a hint as to the issue. I copied the pertinent errors for this issue. I am attaching it for you to view.

  • calvinrogercanas
    • New Recruit

    Hi @F. Zaria,

    Hope you're well!

    You can modify post_max_size and max_execution_time in php.ini file where you can also find in your cpanel. The error indicates that the script return the data even it is not finish executing that's why the course is not complete.

    Please advise if you already modify the php.ini and check if the error still persist.

    Hopefully this will fix the issue.

    Best Regards,
    Calvin

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    It first copies the data, then has to process it and change the ID's and other identifiers to differentiate from the course you are copying, so that there are no collisions when it's then saved as a new course, this is all done on the fly. Also remember, it's not just the courses plugin that is running & using processes, the whole site is also using resources & running processes too, more so if you have lots of visitors viewing and using the site, so all these processes add up concurrently.

    Hopefully these changes will have fixed the issue, but should it return then feel free to re-open the thread or start a new one and we can then take a deeper look into it again.

    Hope this helps & have a great weekend.

    • FZCU
      • The Incredible Code Injector

      Hey, its working at a hit or miss rate right now...half the time it goes through, the other half it does not, and I keep having to repost questions. I'm also forced to save each page one at a time because I am not sure if creating pages in bulk will go though at once. I have gone as far as to increase the max load time to 90 sec and the max post to 1gb and I am still experiencing this issue. What should I do?

  • Vinod Dalvi
    • WP Unicorn

    Hi F. Zaria,

    Are you getting the same "500 internal server" error message when duplicating the course and it does not duplicate the course to the full extent?

    The issues does not occur on my other "lighter weight" courses. I think it has something to do with page numbers. I noticed that once the page number goes past 14, the issue starts to occur

    Could you please share me your course URL that is facing this issue so that i can troubleshoot it on your site by accessing it through support staff access?

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.