during activate plugin I got this error: Warning:

Hello,

during activate plugin I got this error:

Warning: require_once(includes/class-wpmudev-dashboard-site.php): failed to open stream: No such file or directory in /var/www/wordpress/wp-content/plugins/wpmudev-updates/update-notifications.php on line 114

Fatal error: require_once(): Failed opening required 'includes/class-wpmudev-dashboard-site.php' (include_path='.:disappointed:usr/share/php:disappointed:usr/share/pear') in /var/www/wordpress/wp-content/plugins/wpmudev-updates/update-notifications.php on line 114

What should I do to fix it?

The server system is Debian 8.

Thanks in advance

  • Adam Czajczyk

    Hello Rafa?,

    I hope you're doing fine today!

    I'd start with basics which would be checking folders permissions and ownership. It looks like the script is not able to include one of the files so it then searches for it inside default PHP's "include" folders. This is often the case if either folder permissions are to strict and/or an owner of the folder/files is different than the user:group that your web server is running as.

    Try setting permissions for "/wp-content/plugins" folder (recursively, so it would be applied to all the sub-folders and files) to "755" first and if this helps you may try to make it more strict then (e.g. 644) and see if this is still working.

    Also, please check what's the user:group of your web-server (which by default should be Apache) and make sure that these folders are owned by the same user:group.

    In case you'd need more assistance on this, let me know please and I'll be happy to help.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.