E-newletter no permission for Administrators for sub site

E-newletter has no permission for Administrators for sub site, I have already uninstall and activate in the subsite, but it still shows no permission.

Please help

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hello there, rusdy380! Hope you're well today.

    Would you mind enabling support access so I can understand this issue more? If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Thanks!

  • Jude
    • DEV MAN

    Hey there @rusdy380

    I see the plugin is disabled in your Network so could not test there. Make sure you have set the permissions correctly in the user perms tab. See my screenshot

    Also can you try with the role editor and see if that works ? Usually any role higher than the Editor is automatically given the required permissions as well

    Cheers
    Jude

  • Jude
    • DEV MAN

    Hi there @rusdy380

    Im sorry to hear this, just to clarify I did not do anything on your site. I just saw that the plugin was not activated and got out. Even the screenshot I posted was from my site not your site but my demo site.

    Will gladly help you fix it though. Just tell me what is wrong with the site ? Can you specifically tell me what is broken in your themes ?

    Cheers
    Jude

  • rusdy380
    • Design Lord, Child of Thor

    Hi Jude, I believe it is the wpmu dashboard grant access plugin problem that caused this, my super admin is gone and i am unable to access network sites. Please advise.

    I can give you the username and password for wp-admin and the cpanel access.

    Please advise.

  • Jude
    • DEV MAN

    HI there @rusdy380

    Hope you are doing great. I will look into this, just requesting you to backup the whole site and the DB. Also can you send in the details I will need as shown below

    Subject: "Attn: Jude Rosario"
    - WordPress super admin/ admin username + password
    - FTP credentials (host/username/password)
    - cPanel details
    - phpMyAdmin details ( To check database )
    - MySQL details ( IF you dont have phpmyadmin)

    -link back to this thread for reference

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Cheers
    Jude

  • Jude
    • DEV MAN

    Hey @rusdy380

    Sorry the response took a while, this issue is somewhat complex and this is the first time I'm hearing of our Dashboard corrupting database tables.

    Your wpmu dashboard 'Grant Access' corrupted my global db ,table : site meta as I use multi db plugin. And when cPanel restore , it only restore one db hence the access to network setting is not avail as it is control by the global db.

    This makes sense you should not use the cPanel restore as it does not have the metadata needed for MultiDB. I still can't figure why the corruption actually happened.

    So what I did is asked the hosting provider to repair the site_meta table and everything back online but I am not sure wether my multi db is working correctly.

    Can you tell me what you did for this repair process ? Did you selectively import one table from a backup or a full restore ?

    Can you please check if my multi db is working fine? And what cause the site_meta table to be corrupted.

    I have asked for the developers feedback on this, like I said I checked with a few people and we cant seem to recall this ever happening before

    Questions :
    1. How do i know multi db is working fine

    I scanned through the tables and was not able to see anything out of the ordinary yet. I will do it again one the developer gets back to me

    2. How do i back up multi db

    There are a bunch of fancy tools but nothing comes close to the raw power that mysqldump gives you.

    Here is a good read 0n how to back up and restore databases independent of tools like cPanel restore / phpMyAdmin etc ..

    http://dev.mysql.com/doc/refman/5.5/en/backup-strategy-example.html

    3. Why cant i see all the multi db in mysqldatabase in the cpanel. It can only be viewed in phpmyadmin?

    Here again cPanel is very limited when processing distributed DB systems. Im not sure if it has the capabilities to read meta information from your tables and put everything together.

    5. Why is multi db causing website to slow down.

    Im not sure if its Mutli DB here, its merely a slice and dice type tool. Can you do a couple of tests using Pingdom and Google Site speed and let me know your results ? Also can you try this tool to see which specific plugin is causing this

    https://wordpress.org/plugins/p3-profiler/

    Cheers
    Jude

  • rusdy380
    • Design Lord, Child of Thor

    Hi Jude,

    Thx for the prompt reply.

    1. The repair process : I believe the only restore the site meta table which has the Super Admin details. So i am not sure wether the rest of the databases are working properly at this time. Probably you can give a heads up on how to verify. Perhaps you can explain the process of what will cause databases to change and which database will be affected when we install plugins or theme or add pages. This will help us to prepare ourselves better in dealing with sudden mishaps like this.

    Or suggestion : Create a script to very that our multi db is working correctly.

    2. As u mentioned, u have informed the developers to check on wether the multi db is working correctly. Will wait for your reply on this matter.

    3. As for the speed of the website, i am already using the plugin u suggested but that does not check mysql queries speed.

    Thank you

  • Jude
    • DEV MAN

    Hey @rusdy380

    Just keeping you in the loop. The developer of eNewsletter looked into your site earlier today and here is what he told me.

    Administrators have all eNewsletter capabilities by default
    Also Admin permissions are checked and reset each time the admin page is opened

    So it looks like something easy to fix, but we were not able to find the plugin installed so could not test / make further progress there.

    Will keep you posted on the MultiDB issue progress. Once again sorry for the delays here. We value you as a member.

    Cheers
    Jude

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.