E-newsletter as Email provider

You say in docs:
"Select your mail service (currently, we support MailChimp, AWeber, Constant Contact, GetResponse, Sendy, Mad Mimi, Infusionsoft, Campaignmonitor and our very own e-Newsletter.) "

E-newsletter is not in the dropdown.
Have sync on, I've setup a mail server that tests OK.

  • Predrag Dubajic

    Hi Ian,

    That explanation is there because you can still save the subscriptions to local list exportable as CSV even if the e-Newsletter is not installed on your site.

    e-Newsletter simply uses that list to import members to selected group.

    But it doesn't help.

    Not sure what do you mean, I saw previously that you did have group selected for sync, are you saying that the subscribed members are not added to that group?

    Please advise.

    Best regards,
    Predrag

  • Ian, Tringa Studio

    Hi

    The documentation is completely wrong then.

    "Select your mail service (currently, we support MailChimp, AWeber, Constant Contact, GetResponse, Sendy, Mad Mimi, Infusionsoft, Campaignmonitor and our very own e-Newsletter.) and enter the required information. Detailed instructions for each service we support can be found at the end of this guide."

    It's not in the dropdown and there is no explanation at the end!!!

    Anyways, I uninstalled both plugins to get a clean start and tried what you wrote. But see below!

    I set up a slide in and I get: a slide in, a popoup, something at the end of an article and a window saying "Join". Is that garbage from the database files that were not deleted (again, see below).
    You have access so check this out because it's clearly not working!

    In the Optins page it also says "Newsletter No Email Service" at the top.

    Nothing happens when I fill out the top form even though it says I'm subscribed.
    If I close all the overlapping forms and fill out the Slide in I made, it tells med that something went wrong when I use the same adress again, and yet it's not in the database i E-newsletter.
    If I use a new address it tells me Congrats again! Still no mails though. And yes the email server is set up and works wit the test mail.

    ---------
    Another problem. I deinstalled E-newsletter and Hustle to get a clean start but there are loads of tabels still in the DB named:
    wp_b5e1f759fd_4_enewsletter_groups, wp_b5e1f759fd_4_enewsletter_members, wp_b5e1f759fd_4_enewsletter_member_group, wp_b5e1f759fd_4_enewsletter_meta, wp_b5e1f759fd_4_enewsletter_newsletters, wp_b5e1f759fd_4_enewsletter_send, wp_b5e1f759fd_4_enewsletter_send_members, wp_b5e1f759fd_4_enewsletter_settings

    Seems to be from your plugin or?

  • Adam Czajczyk

    Hello Ian!

    The documentation is completely wrong then.

    I checked the docs and that might be confusing so I have already reported it to our writers asking them to correct it and add more details about E-Newsletter integration setup.

    I set up a slide in and I get: a slide in, a popoup, something at the end of an article and a window saying "Join". Is that garbage from the database files that were not deleted (again, see below).
    You have access so check this out because it's clearly not working!

    I have accessed and checked your site. There's a "Newsletter" e-mail opt-in with a "Slide-in" active and that shows up on the page. It seems to be properly set to add mails to "Newsletter" E-newsletter's group and when I used that slide-in to subscribe my e-mail was added as a member to E-Newsletter and assigned to that group, as expected. Trying to use the same e-mail one more time resulted in an error which should be happening.

    You mentioned that when you try to use the same e-mail second time it triggers error even though e-mail is not in database or on member's list. Can you tell me what that e-mail is (I have marked this thread as internal so only you and staff members can see it)?

    Could you also please point me to the "top form" that you mentioned here:

    Nothing happens when I fill out the top form even though it says I'm subscribed.
    I can see the slide-in form on the site but I"m not sure what do you mean by the "top form" and I would like to take a closer look in order to check why that doesn't work for you.

    If I use a new address it tells me Congrats again! Still no mails though. And yes the email server is set up and works wit the test mail.

    The "Double opt-in" option and "Welcome e-mail" option in E-Newsletter plugin are disabled on your site. As a result the plugin will not send any e-mails automatically upon subscription. It will only send them when you trigger one of the newsletters. Did you mean that these newsletters are not delivered to the members after you click "send"?

    Please advise!

    Kind regards,
    Adam

  • Ian, Tringa Studio

    If I go here in an anonymous tab (I can't see any Hustle forms when logged in even if I change settings to show)

    https://tswb-dev.com/enewsletter/test-page/

    I get what you see in the image, 4 forms on top of each other.

    My bad about the Opt-in, got reset when I deleted plugin. Even though they are on, still no optin or welcome mails are sent. I'm added as a subscriber but that's it.
    What else am I doing wrong in my setup?

    What about all the database tables left behind?

  • Predrag Dubajic

    Hi Ian,

    If I go here in an anonymous tab (I can't see any Hustle forms when logged in even if I change settings to show)

    In your Hustle > Settings panels you have disabled modules from showing to admins, that's why they are not visible to you while logged in:

    My bad about the Opt-in, got reset when I deleted plugin. Even though they are on, still no optin or welcome mails are sent. I'm added as a subscriber but that's it.

    I did some tests on my installation and also had some issues with sending newsletter welcome emails from Hustle form, I have reported this to our developers so they can check it out and see what might be going on.

    What about all the database tables left behind?

    There's an option under e-Newsletter > Settings > Uninstall panel where you can clear the database entries of the plugin.

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello Ian!

    The update for Hustle took away most of the multiple dialogs. Have to check my settings but I still have 2 showing.

    I'm not quite sure if I get your point on this. Would you mind explaining that a bit more? Some screenshots would also help. If that turns out to be some confusion with UI/plugin features, I'll be happy to explain that but if it turns out to be some bug/glitch, I'll report it to developers.

    A plugin should clean up after itself! So what you are saying is that I have to activate it on all sites where I've had in installed and check Clean database and deactivate again, then delete the plugin?

    Yes, that would be the most reliable option. The plugin stores quite a bit of data that may be re-used in future clearing them up would result in a number of issues related to "how to restore all the subscribers". That's why data removal in this case is optional.

    Kind regards,
    Adam

  • Ian, Tringa Studio

    Hi again
    Time to solve this.
    Never mind about all the overlapping windows. It's working now after a few updates of Hustle.

    I get what you say about the uninstall.

    The problem still is that even though I can send a test mail (mail server setup seems to work) I get no Optin. Or welcome mail if I turn it off.
    You have access to the site already because of another bug on an other site.

    Try it and see what's wrong.

    Cheers

  • Dimitris

    Hey there Ian, Tringa Studio,

    hope you're doing good and don't mind chiming in! :slight_smile:

    I just inspected your website and opt-in form seems to work for me. I was able to subscribe with a test account and reports seems to be correct in backend.

    Also I was added in e-Newsletter group successfully.
    If you want to activate the double opt-in, you should be doing that here:

    I'd rather advise this at least until the welcome message issue get resolved by our devs.

    Warm regards,
    Dimitris

  • Dimitris

    Hey there Ian, Tringa Studio,

    hope you're doing good!

    I just accessed your website and I subscribed with a new email.
    I've got my welcome email and I can see that this latest subscription is both visible in Hustle's opt-in listing page here:
    /enewsletter/wp-admin/admin.php?page=inc_optin_listing
    and in eNewsletter Members list here:
    /enewsletter/wp-admin/admin.php?page=newsletters-members

    Am I missing something? Is there another aspect that still doesn't work? Please advise!

    Warm regards,
    Dimitris :slight_smile:

  • Dimitris

    Hey there Ian, Tringa Studio,

    that is true, I didn't check the double opt-in setting and didn't get any Confirmation email but the Welcome email at once.

    I already notified our devs about it as it seems that double opt-in option isn't working indeed with Hustle forms, even though it still works with eNewsletter widget for example.

    Hopefully this will be resolved in next plugin release, me or another colleague of mine will keep you posted though, if any kind of hotfix can be applied till then.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.