e-Newsletter bug report and fix for TinyMCE editor

My client uses the newsletter plugin and the content wysiwyg in the customizer broke somehow. Did the basic troubleshooting and even rebought the wpmu sub to get updates & upgraded wp.
The error is that the tinymce widget/control doesnt render right so even though the content stores and gets outputted in a js array in the html, its not shown to the end user.
I have a modified zip for the dev team to review: https://gist.github.com/Tabrisrp/13348dbcd2bbb0d9406f

  • viobru

    Hi, Johannes!

    Hope you’re doing well today :slight_smile:

    First of all, thanks for pointing this up and for sharing a fix for this!

    I do apologize but, unfortunately, I wasn’t able to restore the backup of the site using the files you’ve shared. I was able to upload the files, but I’m getting several PHP errors after uploading them related to the WP Autoloader plugin installed on the site and I can’t access it (so I can’t finish the migration of the site). For this reason, I’m going to escalate this to our Second Line Support so they can check it, proceed to confirm the bug and share your fix with our developers. Please understand that in order to apply the fix you’ve shared we’ll first need to confirm the bug by replicating it.

    Many thanks in advance for your patience on this.

    Merry Christmas! :slight_smile:

    Kind regards,

    Violeta

  • Rupok

    Hi Derrick,

    I'm confirming you that Violeta has created a task and assigned that for our Second Level Support. We will update you here as soon as we get an update from our SLS team.

    Please keep in mind, our SLS people work around the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide their valuable feedback on this. I'll appreciate your patience.

    Have a nice day. Cheers!
    Rupok

  • Ari

    Hi Derrick or Johannes,

    Hope you are well,

    Sorry to hear that you are in trouble with our plugin. There is a mistake in our plugin, that's why this problem is happening, I made a temporary fix for this issue, also escalated this to our plugin developers, so we have a proper fix in the future updates.

    ===

    To fix the problem please download the zip file and upzip it, you will see e-newsletter folder with the new files inside. Now:

    1: First update the plugin to the new version.
    2: Then go to: wp-content/plugins/e-newsletter folder with cPanel or FTP.
    3: Then replace the old files with the new files, there are 5 files need to replace:

    1: e-newsletter.php
    2: email-newsletter-files / class.functions.php
    3: email-newsletter-files / class.wp_widgets.php
    4: email-newsletter-files / page-settings.php
    5: email-newsletter-files / builder / class.builder.php

    The above solution works fine in my test site, please check is that works on your end, and let me know the if you have any problem regarding this.

    Cheers, Ari

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.