e-newsletter HTML

I have installed the e-newsletter plugin on our website c21jf.us, and imported some contacts from my existing database. That all works fine.

I am trying to set up an initial "test" newsletter. I choose a template, fill out the settings, when I get to Content I have problems.

The words I type into the "Visual" box do not appear. (It's like they're white ... I can only see them when I highlight them.) I cannot access the HTML tab at all. It's there, but does nothing when I try to click over to it. There is no wysiwyg editor while on the "Visual" tab. It does nothing when I try to email a preview. It does nothing when I click on "save and go to send page" button.

On my other website, hitthegrounddancing.com, I get the HTML editor, the wysiwyg editor, and can see everything in the visual editor. However, when I attempt to send a preview email or a regular email, I get the error "SMTP Error: Could not connect to SMTP host. Mailer Error: SMTP Error: Could not connecto to SMTP host." When I tried to send the bounce email test, it gives me this error "SMTP Error: Could not connect to SMTP host. Mailer Error: SMTP Error: Could not connect to SMTP host." ... but I actually RECEIVED the bounce email test in my inbox.

So my questions are:
1) Why can I not access HTML tab or wysiwyg editor, or do almost anything on one website
2) Why can I not send emails on the other website

Have I installed these both wrong? They were both brand new installations today.

  • aecnu

    Greetings vicky_wu,

    Welcome to WPMU DEV!

    Thank you for the great questions and detailed explanations which are very helpful.

    1) Why can I not access HTML tab or wysiwyg editor, or do almost anything on one website

    This one sounds like a conflict of some sort. Therefore it is time to go into full blown trouble shooting mode because it appears there may be some conflict here and one way to find out conclusively.

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting.

    You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    2) Why can I not send emails on the other website

    On this site what do you have the email sending option set as SMTP or php mail?

    If SMTP do you have valid credentials placed in there to include smtp user name and password of the outbound smtp server?

    Please advise.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.