E-newsletter is sooo slow in sending emails to big lists

My hosting server is capable of sending 60 emails every minute but the it took a long time to send emails using e-newsletter compared to other plugins.

It took me over 12 hours to send to a list of 6000 members; so less than 10 emails a minute. this is extremely slow. Is there anyway to fix this.
I already put wait "1" second between each email in the settings but did not help. I tried putting 0 and still did not help

  • Jude
    • DEV MAN

    Hi there @SPEKSA

    How are you sending out the mails ? Do you have SMTP setup ? Also are you using the default WP - Cron or do you have something that manages cron jobs on the server for you?

    Also I think 60 mails per minute is roughly one mail per second so setting it to zero + clearing cache and resending should fix.

    Cheers
    Jude

  • Maniu
    • Developer

    Hey @SPEKSA

    If you have disabled any limitations and its still slow, there is nothing you are doing wrong. You can try "send now" feature instead of cron - it may be faster this way as cron triggering is based on visitors opening the site.

    I will try to look into any possible performance improvements for this part of plugin. You may try deleting your old newsletters - this should speed things up.

    Thanks,
    Maniu

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.