e-Newsletter - not compatible with SSL / HTTPS

I thought I had reported this before, but I couldn't find it in my history...

Loading this HTTP instead of HTTPS:
http://example.com/wp-content/plugins/e-newsletter/email-newsletter-files/js/widget_script.js?ver=3.3.1

1) why not HTTPS?
2) why loading on this page at all? there's nothing particular for e-Newsletter that I can tell...