e-Newsletter not sending test email.

I am hosting with godaddy but using gmail (apps) for my email. I am trying to set up the e-Newsletter plugin but am getting the error message below when setting up the outgoing email settings.

Failed to send test email! - Please check your outgoing email settings and server config to see if selected ports are open. Error details: The following From address failed: newsletter@aaie.net : Called Mail() without being connected

My settings are as follows:
From Email: newsletter@aaie.net
SMTP Outgoing Server: smtp.gmail.com
SMTP Username: newsletter@aaie.net
SMTP Password: My Gmail Password ****************
SMTP Port: 465 or 587 ( I have tried all combinations with the both ports and secure drop down options below)
Secure SMTP?: SSL or TLS

I am using the info from: https://support.google.com/mail/answer/13287?hl=en

Any thoughs?

Thanks,
William

  • William

    That email address is on the google server. I am using google apps for business and running all my domain emails through google. Not sure if I understand what you are saying but i updated my settings per your suggestion and am still getting the following error:

    Failed to send test email! - Please check your outgoing email settings and server config to see if selected ports are open. Error details: The following From address failed: newsletter@aaie.net : Called Mail() without being connected

    I have attached screen shots for you to take a look.

    Thanks,
    William

  • Sajid

    Hi @William! Hope you are doing good today :slight_smile:

    I did a quick Google search and found this answer with same question but using WordPress simple smtp plugin. The problem was related to gmail apps so it should work for you too :slight_smile:

    I too had a problem with Google Apps Gmail and "Email could not be sent".

    My website is hosted on it's own domain and Google Apps MX records are configured in DNS. Google Apps Toolbox Check MX reports everything is fine: https://toolbox.googleapps.com/apps/checkmx/

    My hosting provider (WPEngine.com) does not offer e-mail services, which if it did can cause other well documented problems because mail will be sent to the hosting provider's local mail servers instead of gmail for the domain. See the Google Apps Forums for more info.

    Two-Step Verification is enabled via the Gmail Security settings (Gmail Account -> Security -> 2-step verification).

    Configured Easy WP SMTP as so:
    From Email Address: wordpress@mydomain.com <-- alias setup in Gmail
    From Name: WordPress
    SMTP Host: smtp.gmail.com
    Type of Encryption: SSL
    SMTP Port: 465
    SMTP Authentication: Yes
    Username: admin@mydomain.com <-- real user in Gmail
    Password: < password used for https://mail.google.com >
    Enable SMTP Debug: Checked

    Sending test e-mails via the "Test & Debug Settings" section of the plugin failed.

    I found the problem in the "SMTP Debug:" output panel. The Google Mail server said "Application specific password required" or something very similar.

    Woo Hoo!

    I logged into the Gmail admin@mydomain account via my web browser, navigated back to the Gmail Account -> Security -> 2-step verification and created a new application password for "WordPress". Pasted the application specific password into the plugin:
    Username: admin@mydomain.com <-- real user in Gmail
    Password: <application specific password for WordPress>

    and e-mail works fine! Sent various test e-mails to Google Apps mail, regular gmail and external domain accounts. No problems!

    I now receive WordPress comment notifications!

    See this URL for more details:
    https://wordpress.org/support/topic/google-apps-smtp-problems

    Let us know the results :slight_smile:

    Cheers, Sajid

  • William

    Hi @Sajid,

    Thanks for your response but this did not help solve my problem.

    I was however able to get Godaddy and Google support on a 3 way call and figure out a solution. Screen shots attached of my final settings.

    When chatting with both tech support people it seemed very clear it was a GoDaddy issue or an issue with the script from the plugin. I chatted for about 45 minutes and tried every possible combination with Google before we got GoDaddy on the line. GoDaddy was finally able to provide the solution but we had to bypass all the Google configurations. The final configurations that worked when using GoDaddy as a host and Google Apps For Business are as follows:

    From Email: email@domain.com
    SMTP Outgoing Server: relay-hosting.secureserver.net
    SMTP Username: Leave Blank
    SMTP Password: Leave Blank
    SMTP Port: 25
    Secure SMTP?: None

    I hope this helps anyone else looking for this answer and I think it would benefit WPMUDEV to include some better support/ walk through setups for this. This took me over 4 hours to get configured properly.... :slight_frown:

    Thanks,
    William

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.